Brak możliwości ponownej instalacji windows defender


(kwasior) #1

Witam. Mam pewien problem.. Pewnego razu usunąłem windows defender bo uznałem, że jest mi zbedny. Teraz jednak chciałem pozmieniać ustawienia zapory, jednak gdy wchodze w opcje zaawansowane zapory widnieje taki komunikat:

image_id: 4209

a w ustawieniach zapory coś takiego:

image_id: 4210

Z tym, że gdy klikam użyj ustawień zalecanych wyskakuje mi błąd:

image_id: 4211

Gdy w windows defender (choć go idinstalowałem) kliknę opcję uruchom teraz, wyskakuje błąd:

image_id: 4212

Gdy chcę na nowo zainstalować windows defender, otrzymuję komunikat, że windows defender jest już zawarty w systemie windows. Dodam, że próbowałem zresetować usługi windows programem windows manager, jednak oprócz utraty połączenia z netem nie dało to nic.

Proszę o pomoc..


(system) #2

Może to się Tobie przyda

http://support.microsoft.com/kb/918355/pl


(kwasior) #3

Niestety, program ten nie pomaga. Znajduje problem z aktualizacją i naprawią ją, jednak nic to nie daje. Wydaje mi się, że problem tkwi w rejestrze. Może gdybym usunął z rejestru wpisy windows defender, dałoby rade go zainstalować ponownie? Tylko jak to zrobić..?


(system) #4

sprawdż czy usługa jest atomatycznie włączona

start->panel sterowania->narzędzia administracyjne->i kliknij usługi wyszukaj tam windows defender i sprawdż czy jest automatycznie włączona,jeśli nie to kliknij na niej 2wa razy i rozwinie się menu i ustaw automatycznie i ok


(kwasior) #5

Problem w tym, że nie ma tam na liście w ogóle windows defender..

EDIT: znalazłem na internecie plik z wpisem do rejestru resetującym usługę windows defender.. Usługa ta pojawiła się na liście. Ustawiłem ją na automatyczny. Jest ona zatrzumana, gdy chcę ja uruchomić otrzymuję komunikat:

image_id: 4213

Proszę o pomoc..


(rgabrysiak) #6

W jaki sposób usunąłeś Windows Defender, wydaje mi się że jest on zintegrowany z systemem więc trochę dziwi mnie że w prosty sposób można go usunąć. Spróbuj, na próbę zainstalować MSE. Być może to rozwiąże twój problem.

Możesz także sprawdzić poprawność plików systemowych poprzez polecenie:

wpisane w wiersz poleceń.


(kwasior) #7

Windows Defender usunąłem przez panel sterowania (ale nie jestem pewien na 100 %). MSE już próbowałem instalować, niestety otrzymuję komunikat:

image_id: 4214

Pliki systemowe są ok ("sfc /scannow" nic nie pokazuje).


(Oskar159) #8

Witam,do pobrania program "Iobit Toolbox" możliwe ,że zadziała.

http://www.majorgeeks.com/downloadget.p ... 2873bfab57

Zrób jak na screenie,po skończonej operacji zrestartuj komputer.

beztytuuaao.jpg

Uploaded with ImageShack.us


(papuć) #9

Defender nie jest potrzebny w systemie,zastanawia mnie tylko jak Ci sie udało go usunąć,ponieważ jest zintegrowany z systemem.Jeżeli bardzo chcesz go przywrócic

to chyba tylko z recovery


(kwasior) #10

Niestety użycie programu Iobit Toolbox nic nie dało.. Papuć masz na myśli przywracanie systemu?


(Łukash) #11

Daj linka do tego pliku

Spróbuj w wierszu polecenia uruchomiony jako administrator wpisz/wklej :

regsvr32 "%ProgramFiles%\Windows Defender\mpsvc.dll"

enter i restart systemu

Da się usunąć usługę ,nie które programy mają taką opcję np Vista/7 Manager jest jednym z nich.


(kwasior) #12

link do pliku: http://www.sendspace.com/file/gz0n7p

Po wpisaniu polecenia w cmd mam komunikat:

image_id: 4215


(Łukash) #13

Spróbuj :

regsvr32 C:\ProgramFiles\Windows Defender\mpsvc.dll

ścieżka bez cudzysłowu ,lub z cudzysłowem = "Ścieżka"


(kwasior) #14

po poleceniu:

regsvr32 "C:\ProgramFiles\Windows Defender\mpsvc.dll"

otrzymuje komunikat:

image_id: 4216


(Łukash) #15

Kurde :slight_smile:

Wejdź w folder Defendera > przytrzymaj klawisz Shift i kliknij prawym myszki > z menu wybierz "Otwórz okno polecenia tutaj" .

i wpisz :

regsvr32 mpsvc.dll

Enter .Zaskoczy ,lub nie ,jak nie będzie tego pliku,ale wtedy będziemy bliżej rozwiązania.


(kwasior) #16

dostaję komunikat:

image_id: 4217


(rgabrysiak) #17

Spróbuj tym sposobem:

http://www.brighthub.com/computing/wind ... 67690.aspx

Dokładnei część dot. Windows 7.


(kwasior) #18

Po komendzie:

winmgmt / verifyrepository

dostaję: "repozytorium WMI jest spójne" Po włączeniu windows defendera mam takie okno:[image_id: 4218Gdy chce uruchomić dostaję błąd:

operacja została zwrócona, ponieważ przekroczono limit czasu. (kod błędu: 0x800705b4)

A może pomogłoby tu gdybym zamienił pliki windows defendera (ktoś z Was wrzuciłby folder defendera na serwer i podmieniłbym go z moim). Mam win7 64 bitowy. EDIT: zrekonstruowałem usługę Centrum Zabezpieczeń i Windows Defender. windows defender już śmiga, centrum zabezpieczeń też już działa. Pozostał problem z tą zaporą systemu, screeny:

http://forum.dobreprogramy.pl///gallery/image_page.php?image_id=4209

http://forum.dobreprogramy.pl///gallery/image_page.php?image_id=4210

http://forum.dobreprogramy.pl///gallery/image_page.php?image_id=4211

Wie ktoś może jak temu zaradzić?

](https://forum.dobreprogramy.pl/gallery/image.php?image_id=4218)


(Łukash) #19

Wklej do notatnika :

.

Zapisz jako fix.bat. Kliknij prawym i uruchom fix.bat jako administrator .Potwierdź wykonanie .

Restart systemu.


(kwasior) #20

Nie dało to nic. Nie wiesz może jak zrekonstruować usługę zapora systemu windows? Nie ma jej w services.msc