Brak obrazków w podglądzie napisanej strony html (Firefox)


(Laszjwrz) #1

Witam, mam problem z wyświetlaniem obrazków w przeglądarce firefox 2.0.0.11 w nowo napisanej stronie html (notatnik). Korzystałem ze wzoru na wstawienie zwykłego obrazka

[/code]

i po wpisaniu odpowiedniej lokalizacji pliku w podglądzie strony widzę tylko "Tekst alternatywny" - obrazek się nie wyświetla, jednak klikając prawym myszki na "Tekst alternatywny" widzę opcję "pokaż obrazek" i działa. Wszystko to wygląda tak, że wpisany adres obrazka jest ok, kod html w notatniku tez ok, ale dlaczego się nie wyświetla?:frowning: Nie mam zbyt dużego doświadczenia w pisaniu stron internetowych, muszę wpisać tylko parę zdań i wkleić parę obrazków... Pomocy!

P.S:

Wszystkie pliki znajdują się na moim dysku, nie wysyłałem nic na serwer.


(Airborn) #2

założymy się, że tak nie jest?

pokaż lepiej ten kod który napisałeś


(Laszjwrz) #3

(Xbladex) #4

wydaje mi się, że powinieneś użyć "/" zamiast "\" w ścieżce do pliku

czyli:


(Laszjwrz) #5

Próbowałem - to samo.


(Airborn) #6

zacznijmy od ścieżek... nigdy, przenigdy nie podajemy ścieżek w takim formacie w jakim Ty to zrobiłeś, jeżeli pracujesz na dysku korzystaj z adresów względnych do plików http://webmade.org/porady/adres-bezwzgl ... gledny.php


(Laszjwrz) #7

A tak żebym zrozumiał? :lol: Jak ma więc wyglądać adres?


(Airborn) #8

to zależy jaka jest struktura plików, gdzie plik html, gdzie pliki jpg, jeżeli w tym samym katalogu, to po prostu ./plik.jpg jeżeli wybrał byś metodę stosowaną najczęściej przy tworzeniu stron internetowych, czyli miał plik html i obok niego katalog w którym trzymasz grafikę to było by to ./nazwa_katalogu/plik.jpg dodatkowo powinieneś pamiętać, że wielkie i małe litery w nazwach czy rozszerzeniach nazw plików to nie to samo


(Laszjwrz) #9

No właśnie o to mi chodziło! :slight_smile: Dzięki Airborn - działa, czym się.