Brak obrazu w filmach


(Klytakw) #1


(Bogdan_G) #2

Jaki directx pobrany? Jakie masz zainstalowane microsoft visual studio? Czy jest do windows 7 - SP1?

Do WMP trzeba doinstalować kodeki. Na Media Player Classic, też bym nie liczył.

Najlepiej, to pobrać i zainstalować vlc, czy smplayer. Mają wbudowane kodeki i mogą odtwarzać wszystkie formaty. Można ustawić taki player, żeby domyślnie odtwarzał, a systemowe, to można wyłączyć.

 

Teraz grafika działa. Ten z 2010 directx 9.29 redist, jest dobry http://www.dobreprogramy.pl/DirectX,Program,Windows,12667.html

Pobiera się do utworzonego folderu na pulpicie, czy w moje dokumenty i tam w folderze klika się w DXSETUP.exe, co zsynchronizuje biblioteki w systemie, potem to można usunąć folder z directxem, gdzie się pobrało.

 

 


(bachus) #3

Spróbuj może zacząć od jakiegoś zestawu all-in-one kodeków.

http://www.codecguide.com/download_kl.htm


(Klytakw) #4

DirectX pobrany ten, który podałeś u dołu. Zrobiłem tak jak napisałeś.

VLC - również pobrałem. Z nim jest akurat tak, że po restarcie lapka (nie zawsze) film się otwiera, ale jak np. zatrzymam i włącze ponownie, obraz jest znowu czarny.

Co do pierwszego pytania - mam zainstalowane coś takiego:

c7437374f6.png

 

@up - te kodeki mam, pobierałem najnowszą wersję.


(DarkPeter) #5

http://www.dobreprogramy.pl/DirectX,Program,Windows,12426.html 

Cały DirectX i aktualne biblioteki ściągnie z internetu.


(Klytakw) #6

Właśnie takiego pobierałem.


(DarkPeter) #7

Odinstaluj wszystkie programy do odtwarzania filmów, przeczyść CCleanerem i zainstaluj VLC


(Klytakw) #8

VLC również nie dodaje obrazu. Pobrałem jednak Quick Time i na nim mogę zwyczajnie otwierać pliki z roszerzeniem mp4. Filmy w .avi niestety nie.