Brak pliku hal.dll po skopiowaniu plików przez instalator WinXP


(a2t1) #1

Witam

 

Mam dość ciężki orzech do zgryzienia, gdyż podczas próby uruchomienia dalszej części instalacji WinXP HE, po zakończeniu tej "tekstowej", wyświetla mi się popularny błąd o braku pliku "hal.dll"

 

Mój przypadek jest dość niezwykły, gdyż instaluję w.w system na dysk ATA podpięty z innego (starego) komputera do nowego, gdyż na starym nie ma możliwości bootowania z usb, a napęd CD/DVD już się wysłużył (czyt. nie działa).

 

Poprzez konsolę recovery instalatora próbowałem już rozwiązań takich jak:

copy x:\i386\hal.dl_ z:\windows\system32\hal.dll

bootcfg /rebuild

attrib -h -r -s z:\boot.ini
del z:\boot.ini
bootcfg /rebuild

lecz nadal pojawia się wspomniany komunikat o braku pliku hal.dll. Próbowałem już nawet skopiować go na dysk przy użyciu Windowsa 7, zainstalowanego na nowym komputerze, jednak to również nie podziałało.

 

Dodam, że system jest legalny.

 

Proszę więc o pomoc i z góry za nią dziękuję :slight_smile:


(system) #2

Instalujesz z USB?


(a2t1) #3

Owszem. Bootowalnego pena stworzylem poprzez konsolowe “usb_prep8”, ale próbowałem również “Rufusem”


(system) #4

Pierwsza komenda którą wpisałeś nie zadziała, bo pliki na płycie Windows są skompresowane. Aby go skopiować musisz najpierw go wypakować. Poczytaj ten temat:

http://forum.dobreprogramy.pl/windows-xp-uszkodzony-plik-haldll-t397527/


(a2t1) #5

Komendę “expand” juz zastosowalem ale tez nie zadzialala.

 

EDIT:

Już sobie poradziłem :slight_smile: Stworzyłem bootowalnego pendrive’a za pomocą programu WinToFlash.

 

Rada dla osób z problemem podobnym do mojego - popróbujcie z różnymi programami do tworzenia bootowalnych pamięci :wink: A nuż któryś zadziała ;p