"Brak pliku NTLDR" - Błąd podczas uruchamiania Windowsa XP


(system) #1

Witam!

 

Mam pewien problem... Dzisiaj mój komputer stacjonarny odmówił posłuszeństwa.

Gdy go uruchomiłem ukazał mi się komunikat: "Brak pliku NTLDR" 

Uruchomiłem konsole odzyskiwania, po czym skopiowałem plik z oryginalnej płyty Windowsa na dysk twardy poprzez:  *copy h:\i386\ntldr c:*

Niby pomogło, ponieważ zniknął komunikat o braku pliku NTLDR, ale za to komputer podczas uruchamiania się restartuje.

Za pomocą polecenia fixboot próbowałem nadpisać nowy sektor rozruchowy, nie pomogło.

Ostatecznie uruchomiłem sprawdzanie dysku za pomocą:  chkdsk c: /r

Niestety to również nie przyniosło skutku, więc zwracam się do Was z pytaniem.

Co mogę w takiej sytuacji zrobić? Mam backtrack'a liveCD, ale nie mam żadnych narzędzi do naprawy systemu.

 

Tutaj filmik z uruchamiania:

 

 

Pozdrawiam!


(kalitt) #2

Spróbuj jeszcze fixmbr może pomoże :slight_smile:


(Atis) #3

Uruchom BackTrack Memtest - Run memtest i sprawdź RAM.


(system) #4

fixmbr  nie pomogło, memtest zwrócił:

"Pass complete, no errors, pres Esc to exit"

 

Teraz gdy uruchamiam komputer wyskakuje:

"Warning: System BOOT Fail"

RCjpp12s.jpg


(rgabrysiak) #5

Cześć,

 

Podkręcałeś w ostatnim czasie jakiś podzespół w komputerze? Spróbuj przywrócić domyślne ustawieniaw BIOSie, a jak powyższy bład nadal będzie występował spróbuj wymienić baterię na płycie głównej.


(system) #6

Nie podkręcałem żadnego podzespołu. Po przywróceniu ustawień (opcja "Load Setup Default" ) podczas uruchamiania komputera wyświetla się komunikat: "CMOS checksum error - Defaults loaded" gdy daje kontynuuj następuje restart. Wymiana baterii również nie pomogła.

EOHUf8Ss.jpg


(marcin82) #7

Jak masz Backtrack Linux to podaj wynik skryptu:

http://sourceforge.net/projects/bootinfoscript/ .

 

Przydałoby się też sprawdzić dysk na obecność uszkodzonych sektorów, dla linuksa:

https://wiki.archlinux.org/index.php/badblocks .


(system) #8

Wykonałem ten skrypt, pracował on bardzo krótko, tzn. jakieś 5 sekund i otrzymałem taki wynik:

Boot Info Script 0.61 [1 April 2012]


============================= Boot Info Summary: ===============================

 => Windows is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system: ntfs
    Boot sector type: Windows XP: NTFS
    Boot sector info: No errors found in the Boot Parameter Block.
    Operating System: Windows XP
    Boot files: /ntldr

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 250.1 GB, 250058268160 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488395055 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition Boot Start Sector End Sector # of Sectors Id System

/dev/sda1 * 63 268,414,019 268,413,957 7 NTFS / exFAT / HPFS


"blkid" output: ________________________________________________________________

Device UUID TYPE LABEL

/dev/loop0 squashfs   
/dev/sda1 F2B82049B8200EA3 ntfs       
/dev/sr0 iso9660 BT5

================================ Mount points: =================================

Device Mount_Point Type Options

/dev/loop0 /rofs squashfs (ro,noatime)
/dev/sr0 /cdrom iso9660 (ro,noatime)


========= Devices which don't seem to have a corresponding hard drive: =========

sdb sdc sdd sde