Brak polskich liter w openSUSE Gnome


(D1d2d) #1

Witam. Sorki za brak polskich liter, gdyz mam problem z wprowadzaniem polskich znakow w openSUSE 13.2 Gnome. System zainstalowany z LiveCD Gnome, instalacja rozpoczeta z polskim ustawieniem i polska klawiature. Po instalacji gdy okazalo sie, ze brak jest polskich ogonkow doinstalowalem te pakiety

linux:~ # zypper install bundle-lang-common-pl bundle-lang-gnome-pl myspell-pl_PL translation-update-pl

niby sa prawidlowe ustawienia

damian@linux:~> locale

LANG=pl_PL.UTF-8

LC_CTYPE=pl_PL.UTF-8

LC_NUMERIC="pl_PL.UTF-8"

LC_TIME="pl_PL.UTF-8"

LC_COLLATE="pl_PL.UTF-8"

LC_MONETARY="pl_PL.UTF-8"

LC_MESSAGES="pl_PL.UTF-8"

LC_PAPER="pl_PL.UTF-8"

LC_NAME="pl_PL.UTF-8"

LC_ADDRESS="pl_PL.UTF-8"

LC_TELEPHONE="pl_PL.UTF-8"

LC_MEASUREMENT="pl_PL.UTF-8"

LC_IDENTIFICATION="pl_PL.UTF-8"

LC_ALL=

ale nie mozna wprowadzac ich ani w terminalu ani tez w graficznych programach typu gedit.

GRUB_CMDLINE_LINUX_DEFAULT=" quiet lang=pl_PL splash=silent quiet showopts"

Nawet przeladowalem GRUBa2

linux:~ # grub2-install /dev/sda

linux:~ # grub2-mkconfig -o /boot/grub2/grub.cfg

a i tak nic to nie pomoglo. Co ciekawe instalacja z LiveCD KDE nie stwarza takich problemow, gdyz od razu sa polskie litery.

 


(marcin82) #2

W ustawieniach środowiska graficznego sprawdź. Język polski ma być na górze listy. Angielski możesz usunąć.


(D1d2d) #3

Dzięki za odpowiedź. Zanim ją przeczytałem to doinstalowałem bazowy sytem KDE

linux:~ # zypper install kdebase4-session

Po restarcie wybrałem KDE Plasma Workspace i tu w panelu Keyboard settings są do wybory klawiatury polska i angielska, która jest domyślna. Na niej brak polskich liter, po zmianie na pl są już polskie litery. Po przelogowaniu na Gnome znów brak polskich, w YaST > Keyboard Layout jest cały czas polski, po zatwierdzeniu nastąpiła Aktualizacja systemu i były polskie litery, a w Language podstawowy język polski. Restart logowanie w Gnome i znów brak polskich liter. Przelogowałem się na KDE i zmiana w panelu układu klawiatury na pl. Trochę to pochrzanione aby nie można było na stałe ustawić polskich liter. Może jest sposób aby konsolowo to skonfigurować?


(roobal) #4

Gnome ma swoje ustawienia klawiatury. Zmień tam też na polski i powinno działać. Jak nie, to pomoże nieśmiertelne.

setxkbmap pl

Jak uda Ci się rozwiązać problem, to prosiłbym o późniejsze poprawienie postów.


(D1d2d) #5

Ta komenda w Gnome jest skuteczna do kolejnego przelogowania lub restartu.

W KDE po zainstalowaniu pakietów:

linux:~ # zypper install bundle-lang-common-pl bundle-lang-kde-pl myspell-pl_PL translation-update-pl

linux:~ # zypper install kde4-l10n-pl kde4-l10n-pl-data

w Konfiguracji Desktopu > Preferred Languages dodałem Polski, w Keyboard settings > Układy klawiatur dodałem pl , przesuń w górę i zastosuj i od tej pory jest klawiatura z polskimi literami.

 

Jest jedno zastanawiające, że w trakcie instalacji czy to z LiveCD Gnome czy też LiveCD KDE w opcji ustawiania hasła dla administratora jest pole do przetestowania liter i polskie litery są tam prawidłowo wyświetlane, a po zainstalowaniu systemu nie ma domyślnie takich ustawień. W KDE już wiem jak to zrobić, w Gnome jest tymczasowe rozwiązanie poleceniem setxkbmap pl.


(Jusko) #6

 

Wsadź ją zatem do autostartu :wink:


(roobal) #7

Czy wspominałem, że jest inaczej? :wink: Od biedy możesz te polecenie wrzucić /etc/rc.local lub jak pisano wyżej, wrzucić do programów startowych dla samego Gnome.


(D1d2d) #8

Zanim zacznę kombinować ze wstawkami ustawień do programów startowych, sprawdziłem z ciekawości jak wyświetlane są polskie litery w openSUSE 13.1 Gnome i tu o dziwo po instalacji z Live CD bez problemu są wyświetlane nasze litery. Właśnie piszę z tak zainstalowanego Suska 13.1 Gnome. Pierwsze to sprawdziłem czy w GRUB2 są jakieś inne wpisy

GRUB_CMDLINE_LINUX_DEFAULT=" quiet quiet liveinstall lang=pl_PL splash=silent quiet showopts"

czyli prawie to samo co w 13.2. Plik konfiguracyjny z 13.1 /etc/sysconfig/keyboard też jest taki sam jak w wersji wyżej. Co może być przyczyną, że w 13.1 są polskie litery a w 13.2 ich nie ma.

Ponadto na stronie SUSE są do pobrania obrazy ISO zawierające dodatkowe pakiety językowe

openSUSE-13.2-Addon-Lang-x86_64.iso

i tutaj niemiła niespodzianka - brak wsparcia dla j. polskiego.

Co może być przyczyną, że zainstalowany openSUSE 13.1 LiveCD Gnome prawidłowo wyświetla polskie litery a 13.2 ma problemy z ich wyświetlaniem? W których plikach konfiguracyjnych szukać tych ustawień?


(D1d2d) #9

Polskie litery w openSUSE Gnome 13.2 :

Przy instalacji wybrałem F2 > Language > English (US) > system zainstalował się w ang. wersji. Następnie All Settings > Keyboard > Input Sources > Input Sources (domyślnie był English (US)) > kliknięcie na ikonkę z plusem > Add an Input Source > na samym dole ikonka z trzema kropkami > kliknięcie jej wyświetli długą listę z dostępnymi językami > Polish > Polish > Add > w Input Sources były już dwie pozycje English (US) i Polish > po usunięciu angielskiej została tylko polska > i po restarcie są już na stałe polskie litery. Dodatkowo spolszczenie systemu poprzez instalację polskich pakietów, w ustawieniach Region i Language wybranie j. polskiego, podobnie w Yast w Language ustawienie j. polskiego wraz z układem klawiatury na j. podstawowy.