Brak w menu: Nowy dokument tekstowy


(Vcx3) #1

Witam!

Temat był opisywany wiele razy, ale jak przejrzałem rady z archiwum, to albo coś źle robię lub żadna z rad u mnie nie działa. Wczoraj zauważyłem, że jak klikam prawym przyciskiem myszki na pulpicie, to z wyświetlanego menu zniknęła opcja Nowy dokument tekstowy, czyli notatnik. Mogę otworzyć notatnik z menu Start, ale klikając na pulpicie nie mam takiej możliwości.

Znalazłem różne rady, np. by zmieniać zapisy w rejestrze:

HKEY_CLASSES_ROOT.txt

Domyslna=txtfile

HKEY_CLASSES_ROOT.txt\ShellNew

NullFile=""

Szukasz txtfile co daje:

HKEY_CLASSES_ROOT\txtfile

Zmieniasz zapis w wartosci Domyslnej = np. z "Dokument tekstowy" na dowolny.

Ale jak patrzę u mnie katalog .txt wygląda chyba dobrze bez zmian, a katalogu .txtfile w kluczu HKEY_CLASSES_ROOT wcale nie ma.

daslg.jpg


(skandyn) #2

http://www.tricks.com.pl/dodawanie-pozy ... ekstowego/

http://www.komputerswiat.pl/download/11 ... stowe.aspx

Pozdrawiam.


(Vcx3) #3

Dzięki za szybka podpowiedź. Porady z pierwszego linku, z dopisaniem w rejestrze już wcześniej próbowałem. Albo coś wpisuje nie tak lub u mnie to nie działa.

Aha, w punkcie 4. pisze, by zmienić nazwę Domyślna na np. Notatnik, ale jak jest tylko Domyślna to nie da się zmienić jej nazwy. Nawet wpisałem jako wartość Notatnik, ale to nic nie daje.

1. Uruchom Edytor rejestru (Start/Uruchom/regedit).

2. Odszukaj i kliknij gałąź HKEY_CLASSES_ROOT\Directory\shell.

3. Kliknij na Nowy/Klucz i wpisz regedit (w rzeczywistości nazwa ta jest dowolna).

4. Przejdź do utworzonego wcześniej klucza, po prawej części okna widnieje tam wartość o nazwie (Domyślna), na którą kliknij i wpisz nazwę, pod jaką dostępna ma być opcja w menu kontekstowym np. Edytor rejestru.

5. Utwórz nowy podklucz o nazwie command, tak aby powstał klucz HKEY_CLASSES_ROOT\Directory\shell\regedit\command.

6. W kluczu command, kliknij na wartość (Domyślna) i wpisz ścieżkę do programu (jeśli znajduje się on w katalogu Windows/system32 wystarczy sama nazwa) np. regedit.exe. W ten sposób możesz wedle upodobania dodać inne pozycje do menu kontekstowego.

xgs.png


(skandyn) #4

Możesz spróbować przez przywracanie systemu, naprawić ten błąd w rejestrze.

Pozdrawiam.


(Vcx3) #5

Hmm... wczoraj próbowałem przywracaniem, ale bez rezultatu. Chyba wiem skąd ten problem, to wynik czyszczenia rejestru jednym z programów. Niby przywróciłem w nim z kopi bezpieczeństwa wszystko, co wyczyścił, ale notatnika nie ma. Tak jak pokazałem wyżej, nawet jak zrobię nowy wpis w rejestrze z notatnikiem, to nie zmienia on menu po kliknięciu na pulpicie PPM.


(Łukash) #6

Spróbuj to naprawić programem TuneUp Utilities>System Control>Typy plików >Nowe menu>Dodaj ,wskaż jakiś plik .txt w oknie >ok

Lub zapisz jako .reg dodaj do rejestru.

Windows Registry Editor Version 5.00


[HKEY_CLASSES_ROOT\.txt]

@="txtfile"

"PerceivedType"="text"

"Content Type"="text/plain"


[HKEY_CLASSES_ROOT\.txt\PersistentHandler]

@="{5e941d80-bf96-11cd-b579-08002b30bfeb}"


[HKEY_CLASSES_ROOT\.txt\ShellNew]

"NullFile"=""


[HKEY_CLASSES_ROOT\txtfile]

@="Text Document"

"FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\

  00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,\

  32,00,5c,00,6e,00,6f,00,74,00,65,00,70,00,61,00,64,00,2e,00,65,00,78,00,65,\

  00,2c,00,2d,00,34,00,36,00,39,00,00,00

"EditFlags"=dword:00010000

"BrowserFlags"=dword:00000008


[HKEY_CLASSES_ROOT\txtfile\DefaultIcon]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,\

  65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,31,00,35,\

  00,32,00,00,00


[HKEY_CLASSES_ROOT\txtfile\shell]

@="open"


[HKEY_CLASSES_ROOT\txtfile\shell\open]


[HKEY_CLASSES_ROOT\txtfile\shell\open\command]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\

  54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,25,00,31,00,00,\

  00


[HKEY_CLASSES_ROOT\txtfile\shell\print]


[HKEY_CLASSES_ROOT\txtfile\shell\print\command]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\

  54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,2f,00,70,00,20,\

  00,25,00,31,00,00,00


[HKEY_CLASSES_ROOT\txtfile\shell\printto]


[HKEY_CLASSES_ROOT\txtfile\shell\printto\command]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,6e,00,6f,00,\

  74,00,65,00,70,00,61,00,64,00,2e,00,65,00,78,00,65,00,20,00,2f,00,70,00,74,\

  00,20,00,22,00,25,00,31,00,22,00,20,00,22,00,25,00,32,00,22,00,20,00,22,00,\

  25,00,33,00,22,00,20,00,22,00,25,00,34,00,22,00,00,00

(Vcx3) #7

Zapisałem do notatnika z rozszerzeniem .reg i dodałem do rejestru.

Zadziałało, znowu mam Dokument tekstowy w menu po kliknięcie PPM na pulpit.

Dzięki Łukash, skandyn za pomoc, pozdrawiam :slight_smile: