Brakujące paczki podczas instalacji programów openSUSE


(Koszal No 1) #1

witam tak jak w temacie ile razy chcę coś zainstalować to w 90% cały czas mam jakiś błąd np taki "

http://zapodaj.net/0fc6881b30da.png.html

co można zrobić jaka jest przyczyna?


(Simon1991) #2

Audacity instalowane z repozytorium przez YUMa?


(nintyfan) #3

W którymś wydaniu OpenSUSE wyłączono przeszukiwanie repozytoriów internetowych podczas instalacji lokalnych paczek. W repozytoriach tego programu/tej paczki nie ma?

Włącz Yasta i skorzystaj z modułu "informacje o wydaniu". Może tam znajdziesz informacje, jak włączyć przeszukiwanie repozytoriów podczas instalacji paczek lokalnych.

Jest jeszcze download.opensuse.org lub WebPim w Yaście. Korzystając z Yast One Click Install wszystko pięknie powinno się zainstalować.


(Koszal No 1) #4

ok w repo znalazłem i zainstalowałem. Jednak nie wszytko jest w repo i czasem trzeba jakiegoś rpm-a z netu pobrać i wtedy też jest problem że cały czas czegoś brakuje.


(etam) #5

Dziwne... libid3tag jest w głównym repozytorium openSUSE-11.2-Oss. libvamp-hostsdk3 jest natomiast w repozytorium Packman. Poza tym nie wiem dlaczego ściągałeś gdzieś z neta audacity, bo też jest na Packmanie.

Uruchom YaST -> Repozytoria oprogramowania i zobacz, czy nie masz za dużo powyłączane. Poza tym wybierz dodaj -> Repozytoria społeczności -> zaznacz "Packman Repository", ewentualnie Repozytorium Główne (Contrib) też nie gryzie -> ok

A zanim cokolwiek ściągniesz z neta, to sprawdź na http://software.opensuse.org/search i http://packages.opensuse-community.org/ czy gdzieś nie ma.


(nintyfan) #6

Patrz na mój poprzedni post. Jestem prawie pewien, że repozytoria są wyłączane podczas instalacji lokalnych paczek(np. z płyty CD). Pojęcia nie mam czemu. Jeżeli korzystasz z nowszych wydań OpenSUSE, to sam sprawdź.