Code::blocks allegro linux


(pain3hp) #1

Może ktoś pomóc w dołączeniu bibliotek allegro w code::blocks? Próbowałem dołączyć w linkerze allegro.h ale mimo tego nie widzi go


(nnick) #2

Ale nie dołącza się plików nagłówkowych tylko skompilowane biblioteki... Dorzuć liballeg do linkera i tyle


(pain3hp) #3
/home/kamil/c++/Kode/main.cpp|2|fatal error: allegro.h: Nie ma takiego pliku ani katalogu|

||=== Build finished: 1 errors, 0 warnings ===|

dałem do linkera liballeg.a oraz liballeg_s.a ...

-- Dodane 18.09.2011 (N) 14:29 --

błąd jest w #include


(Juszczyk Pawel) #4
  1. Rozróżnij linker od preprocesora oraz pliki nagłówkowe od libów

  2. Preprocesor musi wiedzieć, gdzie szukać pliku allegro.h. oznacza, że preprocesor będzie szukał pliku nagłówkowego w standardowej lokalizacji. Jeśli znajduje się on gdzieś indziej, to albo w dyrektywie #include musisz podać odpowiednią ścieżkę, albo ustawić poprawnie opcję -I kompilatora


(Razi) #5

A zainstalowałeś liballegro4.2 -dev z repozytorium, albo skompilowałeś i zainstalowałeś ręcznie jakieś nowsze?


(pain3hp) #6

dzięki za zainteresowanie.

Zrobiłem to teraz i błąd wyrzuca przy instrukcji allegro_init();, (przeszło przez #include więc jest krok na przód :slight_smile: )

/home/kamil/c++/Kode/main.cpp|4|undefined reference to `_install_allegro_version_check'|

Proszę o wsparcie

-- Dodane 18.09.2011 (N) 20:10 --

codeblocks instalowalem z repozytorium , nie wiem gdzie jest wgrane ale przeszukałem dysk na folder codeblocks, znalazło 4 i nie widzę żadnego sensownego gdzie mógłbym wgrać te biblioteki.... ogólnie nie wiem czemu ale całe to allegro silno śmierdzi mi windowsem


(Razi) #7

Do opcji linkera dodaj -lalleg (w ustawieniach projektu dodajesz w zakładce Linker "alleg"), albo w innych komendach czy jak to się tam nazywało allegro-config --libs (albo to co ten program wywala).


(pain3hp) #8

-------------- Build: Debug in Kode ---------------


Linking console executable: bin/Debug/Kode

g++: allegro-config: Nie ma takiego pliku ani katalogu

Process terminated with status 1 (0 minutes, 0 seconds)

0 errors, 0 warnings

(Razi) #9

wywaliłeś odwrócone apostrofy `. Są one używane w bashu do wklejenia w dane miejsce instrukcji tego, co wypisze dany program. Program/skrypt allegro-config z pakietu liballegro4.2-dev zwraca wszystkie potrzebne instrukcje do linkera.


(pain3hp) #10

nie rozumiem do czego zmierzasz? w czym problem?


(Juszczyk Pawel) #11

@pain3hp używanie Google nie boli

http://ubuntuforums.org/showthread.php?t=53191

http://www.dreamincode.net/forums/topic/56986-adding-the-allegro-library-to-codeblocks-in-ubuntu-804/


(Przyp Marek) #12

Witam, miałem ten sam problem. Ale rozwiązałem to się dziele. Po instalacji allegro z repozytoriów (u mnie 4.2.2) trzeba dodać do linkera parametr -lalleg-4.2.2 . Klikasz więc Settings -> Compiler and Debugger tam w zakładce Linker Settings w polu Other Linker Options dopisujesz właśnie -lalleg-4.2.2


(etam) #13

A czemu jeszcze używasz allegro4? Od jakiegoś czasu istnieje allegro5. Zainteresuj się tym.