CompizFusion - automatyczny start pod XFCE


#1

Witam.

Mam mały problem ze startem Compiza wraz z odpalaniem XFCE. Mam zaznaczone żeby tak się działo, ale udaje się to raz na 5-6 razy. W pozostałych przypadkach muszę to robić ręcznie.

Dystrybucja - Mint XFCE.


(nintyfan) #2

Myślę, że programy startowe(te ustawione przez użytkownika) są uruchamiane równolegle wraz ze środowiskiem. To może być wyjaśnieniem problemu.

Czy próbowałeś do skryptu włączającego Compiz-Fusion dopisać sleep parę_sekund, albo usleep duża_wartość?

Można też wykorzystać pętlę while i pidof, by sprawdzić, czy menadżer okien XFCE jest uruchomiony w bieżącej sesji, by uruchomić Compiz-Fusion z przełącznikiem --replace.


(mati75) #3

Najłatwiej zrobić za pomocą fusion-icon. Najbardziej pewnie rozwiązanie.


(system) #4

Masz go dodanego do Session Manager`a XFCE.


(dragonn) #5

http://wiki.archlinux.org/index.php/Com ... icon.22.29 ja używam "Method 3"


#6

Żeby to zainstalować, musiałbym jako zależności zainstalować połowę KDE i jeszcze sporo innych, niepotrzebnych mi śmieci.

Wszystkie te rozwiązania także bazują na fusion-icon, więc j.w.

Jest dodany w zakładce "Automatyczne uruchamianie".

A za to nie wiem jak się zabrać.


(dragonn) #7

Że co? Zależność w arch od Fusion-icon:

Zależy od : compiz-core>=0.8.4 pygtk compizconfig-python

hicolor-icon-theme libtool xorg-utils

Nawet qt nie ma, a jest pygtk.


(roobal) #8

Hmm... też mnie to zdziwiło, bo pod Ubuntu nawet żadnych zależności ze sobą nie ciągnie, z tym że ja mam Gnome, więc pewnie wszystko już jest.

Na przykład tak:

#!/bin/shsleep 5--replace[/code]



albo ten drugi sposób, o którym pisał [b]nintyfan[/b]:




[code=php]#!/bin/sh

#9

A gdzie napisałem ze używam na tym komputerze Archa? Cytat z pierwszego posta:

Gdzie znajdę ten skrypt włączający Compiza?


(roobal) #10

To co podałem to musisz przepisać i dodać do autostartu jako nowy skrypt :slight_smile:

Pozdrawiam!


#11

Po wywołaniu ręcznie compiz --replace działa, ale kiedy wrzucam ten skrypt do autostartu do Session Manager`a XFCE ni chuchu nie zaskakuje. Chyba za długo z Linuksa nie korzystałem, bo kiedyś nie z takimi problemami sobie radziłem, a teraz nie potrafię z taką drobnostką sobie poradzić.


(roobal) #12

Ale o nadaniu prawa do wykonania (chmod +x), mam nadzieję, nie zapomniałeś? :slight_smile: Sprawdź jeszcze procesy, zanim uruchomisz Compiza, czy to co napisałem w skrypcie to na pewno Xfwm4, być może ma troszkę inną nazwę.

Pozdrawiam!


(dragonn) #13

Areh to podałem jako przykład. W ubuntu też nie jest dużo inaczej:

Zostaną zainstalowane następujące dodatkowe pakiety:

  mesa-utils python-compizconfig

Zostaną zainstalowane następujące NOWE pakiety:

  fusion-icon mesa-utils python-compizconfig

I naprawdę wątpię w to żeby w Mint fusion-icon wymagało cokolwiek z kde. A gdby przejrzałeś linka którego ci dałem jest tam kilka sposobów (również bez fusion-icon http://wiki.archlinux.org/index.php/Compiz#XFCE). roobal to rozwiązanie na pewno zadziała, ale jest ono nieefektywne, bo najpierw włącza się xfwm4 (którego nie potrzebujemy), a dopiero później compiz.


#14

image_id: 3295

Aż tak kompletnie wszystkiego nie zapomniałem.

To też sprawdziłem. Dokładnie tak to się nazywa. Nie działa ani pierwszy, ani drugi skrypt.


(roobal) #15

A sam skrypt działa jak go uruchomisz w terminalu? Nie montujesz przypadkiem partycji w /home z opcją noexec? Z tego co widzę to tam chce się instalować Compiz ze wsparciem dla Kde, dlatego wymaga zależności KDE ale czemu to chce instalować to mnie dziwi, bo pod Ubuntu z Gnome tego nie wymaga, coś musi być namieszane z zależnościami.

To jest Mint na bazie Ubuntu czy Debiana?

Pozdrawiam!


(dragonn) #16

Areh dobra sorry, widzę że coś w mincie skopali. Powiedz może na początek czy po wydaniu polecenia:

compiz --replace

Włącza się compiz. Bo u mnie muszę robić tak:

compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding

#17

Włącza, ale sypie błędami. Chwilowo nie mam dostępu do tego laptopa, jak będę przy nim siedział, to się odezwę i odpowiem na to i wcześniejsze pytania.

Jest to Mint Mint, ale chyba długo nie posiedzi na dysku, bo te zależności są wkurzające. Chyba w jego miejsce postawię Minta Debian Ed.