Conky na LinuxMint 12 - brak na pulpicie


(greh) #1

Chciałem dodać sobie Conky na LinuxMint 12, ale coś nie działa.

Postępuję zgodnie ze wskazówkami stąd: http://www.ubucentrum.net/2011/02/swiet ... minta.html

ale po wklepaniu polecenia conky w terminalu nic się nie dzieje, a terminal nie wypluwa żadnych błędów, jedynie komendy takie, jakby "rysował" Conky na pulpicie.

Po dodaniu wpisu do Conky do programów startowych i wylogowaniu się i ponownym zalogowaniu Conky jedynie na ułamek sekundy mignie i zniknie.


(GioWDS) #2

Dzińdobry,

spróbuj klepnąć w konsoli

killall conky && conky

(greh) #3

Witam,

Niestety klepnięcie podanej przez Ciebie komendy nic nie zrobiło.

Owszem, zabiło "niewidzialne" Conky, a po chwili uruchomiło kolejne "widmo".

Wnioskuję jedynie po wpisach w terminalu:

Conky: desktop window (1000023) is subwindow of root window (15a)

Conky: window type - override

Conky: drawing to created window (0x3a00001)

Conky: drawing to double buffer

Jakby co, załączam zawartość mojego conkyrc:

# Conky settings #

background no

update_interval 1


cpu_avg_samples 2

net_avg_samples 2


override_utf8_locale yes


double_buffer yes

no_buffers no


text_buffer_size 2048

#imlib_cache_size 0


temperature_unit fahrenheit


# Window specifications #


own_window no

own_window_type override

own_window_transparent yes

own_window_hints undecorate,sticky,skip_taskbar,skip_pager,below


border_inner_margin 0

border_outer_margin 0


minimum_size 200 250

maximum_width 200


alignment tr

gap_x 35

gap_y 55


# Graphics settings #

draw_shades no

draw_outline no

draw_borders no

draw_graph_borders no


# Text settings #

use_xft yes

xftfont caviar dreams:size=8

xftalpha 0.5


uppercase no


temperature_unit celsius



default_color FFFFFF


# Lua Load #

lua_load /home/greh/.lua/scripts/clock_rings.lua

lua_draw_hook_pre clock_rings


TEXT

${voffset 8}${color 339900}${font caviar dreams:size=16}${time %A}${font}${voffset -8}${alignr 50}${color FFFFFF}${font caviar dreams:size=38}${time %e}${font}

${color FFFFFF}${voffset -30}${color FFFFFF}${font caviar dreams:size=18}${time %b}${font}${voffset -3} ${color FFFFFF}${font caviar dreams:size=20}${time %Y}${font}${color 339900}${hr}

${voffset 140}${font caviar dreams:size=10}${alignr}HOME${font}

${font caviar dreams:size=12}${color FFFFFF}${alignr}${weather http://weather.noaa.gov/pub/data/observations/metar/stations/ LQBK temperature temperature 30} °C${font}

${image ~/.conky/linuxmint_main_logo.png -p 60,120 -s 81x27}


${color FFFFFF}${goto 25}${voffset 35}${cpu cpu0}%

${color 339900}${goto 25}CPU

${color FFFFFF}${goto 50}${voffset 23}${memperc}%

${color 339900}${goto 50}RAM

${color FFFFFF}${goto 75}${voffset 23}${swapperc}%

${color 339900}${goto 75}Swap

${color FFFFFF}${goto 100}${voffset 23}${fs_used_perc /}%

${color 339900}${goto 100}Disk

${color FFFFFF}${goto 125}${voffset 25}${downspeed eth0}

${color FFFFFF}${goto 125}${upspeed eth0}

${color 339900}${goto 125}Net




${color FFFFFF}${font caviar dreams:size=8}Uptime: ${uptime_short}

${color FFFFFF}${font caviar dreams:size=8}Processes: ${processes}

${color FFFFFF}${font caviar dreams:size=8}Running: ${running_processes}



${color 339900}${font caviar dreams:size=8}${alignr}${nodename}

${color 339900}${font caviar dreams:size=8}${alignr}${pre_exec cat /etc/issue.net} $machine

${color 339900}${font caviar dreams:size=8}${alignr}Kernel: ${kernel}

(byron_wolf) #4

Witam serdecznie

zdarza się że tapeta przykrywa conky, spróbuj utworzyć pliczek .sh z treścią

#!/bin/bash

sleep 15 && conky &

i z niego odpalać program przy logowaniu. Czasami trzeba też poeksperymentować z opóźnieniem...

Pozdrawiam