Counter Strike 1.6 i Windows 7


(Dawidson 12) #1

Cześć.

Coś dużo problemów sprawia mi ostatnio nowy system Microsoftu. Ledwo co udało mi się jakos skonfigurować system żeby w Enemy Territory wyciągnąć stałe 125 klatek (czyli tyle ile miałem pod poprzednim systemem- Windows XP), a tu problem sprawia mi druga gra- Counter Strike. Nie muszę oczywiście wspominać, że pod poprzednim systemem gra działała płynnie bez większych problemów. Oto jakie kroki poczyniłem, żeby grać normalnie co jeszcze do końca nie wyszło.

  • dodanie Steama jak i samej gry do wyjątków w zaporze

  • uruchamianie Steama i gry w trybie zgodności z Windowsem XP

  • instalacja starszych sterowników Ati (wersja 8.1).

Powyższe sztuczki nadal nic nie daly. Podaje screenshota z gry z właczonym net_graphem, może ktoś obracający się w tych klimatach będzie wiedział jak go interpretować: http://yfrog.com/0ibeztytuusfmj. W sumie teraz trafilem na spokojniejszy moment, ale gra zaczyna zacinać kiedy pojawi się na ekranie przeciwnik - co lepsze na lanie ten problem nie występuje, tylko przy grze przez internet. Dochodzę więc do wniosku, że ta zielona szalejąca kreska jest odpowiedzialna za monitorowanie łącza.

W przypadku ET zauważyłem, że nie mogę grać z włączonym AQQ czy Windows Media Center, ponieważ w samej grze pojawiają się dziwne paski. Oczywiście znikają po wyłączeniu wymienionych wcześniej aplikacji. Nowe sterowniki do mojej karty pogarszają tylko sprawę i samo ET ma około 40fps'ów.

Moj komputer:

C2D E4400 @ 2,5 GHz

Asrock 4coredual-vsta

2x 512 ddr2 @ 667MHz

Ati Radeon x1300xt

Samsung f3 sata2 500gb.

Dodaje tutaj ten wątek, ponieważ gra chodziła na tym samym komputrze z systemem Windows XP bez problemu, więc myślę, że problem stoi po stronie nowego systemu.

EDIT: Windows 7 jest 64-bitowy.


(Łukash) #2

Jeżeli na lanie jest w porządku ,to problem zdaję się być natury sieciowej.

Zdaję mi się że w XP było inne zarządzanie pakietami QoS .Na Vista/7 "rezerwowana" jest pewna przepustowość łącza-20% (pewnie chodzi o jakieś określone porty ). Nie wiem czy to może mieć bezpośredni związek z opisywanymi przez Ciebie problemami ,ale jeżeli tego nie próbowałeś ,to spróbować warto ,nie zaszkodzi i zawszę można wrócić do domyślnych ustawień.

Zrobisz to np w programie 7 Manager > Network > System Network > zaznacz Limit Bandwidtch with the QoS Packed Sheduler Service ,i ustawiasz na 0 .


(MaRa) #3

DirectX9 zainstalowany?

Powyżej 25fps nie ma znaczenia, bo i tak ludzkie oko nie odróżnia.

Karta graficzna dosyć powolna, to nie jest model do gier.


(Dawidson 12) #4

Nadal żadnych efektów. Ten net_graph bardziej obrazuje mój problem- http://yfrog.com/jabeztytuutrij. Jak już wspomniałem wcześniej - robi się taki kiedy spotkam przeciwnika.

@Mara:

Wspomniałem przecież, że wcześniej gra chodziła pod innym systemem na tym samym sprzęcie bez problemu. DirectX jak najbardziej zainstalowany, a poza tym mówienie, że powyżej 25fps'ów nie ma znaczenia, bo i tak oko nie odróznia- proponuje odpalić jakąkolwiek grę i ograniczyć ją do 25fps'ów "bo oko nie odróżnia wiecej", a poźniej wyłączyć ograniczenie.


(Azazel33) #5

Witam, gram w csa dlugi czas i warto by bylo sprobowac zrobic tak ze uruchamiasz steam i ustawiasz jego priorytet na niski w menadzerze zadan, cs tez przestawi sie na niski i u mnie to rozwiazalo problem na win 7, moj kolega tez mial taki sam problem (sic!) i tak samo rozwiazalo problem.


(Łukash) #6

To żadna rada w tym wypadku ,ale mam podobne zdanie jak MaRa , w temacie ,100 klatek to jest płynna gra ,chyba ta różnica nie wpływa na rozgrywkę online (tego nie wiem) .Swoją role może również odgrywać system w wersji 64bit -jak się czyta fora ,to widać że ludzie mają niestety problemy z wydajnością w grach pod 7x64.

Ponadto

Na tym samym sprzęcie wszystko było OK.....


(Dawidson 12) #7

Tu w sumie nie chodzi o spadek fps'ów tylko o to, że wszystkie postacie zaczynają się teleportować co jest bardziej denerwujące niż spadek płynności animacji.


(Łukash) #8

Znalazłem w sieci takie hasła jak choke i loss ponoć to może mieć również wpływ.Tu stronka która ułatwia dobry config

http://cs-guide.net/skrypt/

-- Dodane niedziela, 28 lis 2010, 20:30 --

nargoriel , też napisał coś ciekawego .


(Dawidson 12) #9

Łukash , strona tylko pogorszyła sprawę. Co prawda net_graph zachowuje się trochę inaczej, ale gra stała się niegrywalna.

nargoriel , nie jestem w stanie zmienić priorytetu dla Steama - wyskakuje komunikat o odmowie dostępu.


(Azazel33) #10

jezeli masz duzy choke to warto by bylo wpisac inna wartosc rate np 20000, jednakze wiekszosc serwerow popularniejszych jak hashjama wymusza wlasnie do 20000.


(Łukash) #11

W jakim sensie się pogorszyło ? Czy tracisz jakby więcej pakietów ? Więcej teleportów ?

Jak tak to można wysnuć wniosek ,że to w tych ustawieniach może leżeć problem ,trzeba dobrać optymalne...


(Dawidson 12) #12

nargoriel , próbowałem z rate nawet 100, ale i tak nic nie dało.

Łukash , więcej teleportów i w ogóle jakiś rozproszony ten zielony pasek na net_graphie się zrobił.

Tak na chwilę zostawbiłbym te komendy i nie skupiałbym się na samej grze tylko na ustawieniach sieciowych systemu. Jest jeszcze coś co można z nimi zrobić?


(Łukash) #13

dawidson , jeżeli nie ma problemów z innymi programami które korzystają z sieci tupu komunikator/przeglądarka/coś do pobierania/jeżeli ping jest ok itd ,to raczej nie ma problemu w ustawieniach systemu ....

Na upartego można posłużyć się kolejnym programem Tune Up Utilities > wprowadzić potrzebne informacje i wykonać optymalizację łącza internetowego ,spowoduje to zmianę domyślnych parametrów systemu ,zostaną dostosowane konkretnie dla Twojego łącza.

To raczej w tych ustawieniach jest problem....