Czułość myszy Linux i Win


(happypiotr) #1

Witam, nie mogę rozgryźć tej myszy. Nie chodzi o czułość, bo ją można sobie zmieniać.
Chodzi o to, że w Linuksie ta mysz chodzi tak płynnie, tak jakby w jakimś gęstym środowisku, nie wiem jak to nazwać i przyrównać. Np jakby się kijem mieszało olej lub wodę. W Windowsie 10 (bez sterowników firmowych i czułość nastawiona na max) to przejeżdżam kursorem prawo, lewo, pach pach, jakoś tak dynamicznie i twardo. A w Linuksie to jakoś jakby zapaliło się jointa. Nie mogę tego ogarnąć. Można coś zrobić z tym, aby ta mysz chodziła jak w Windowsie 10?
Już bawiłem się xinput:
xinput --set-prop “Logitech USB Optical Mouse” “libinput Accel Speed” 0
xinput --set-prop “Logitech USB Optical Mouse” “Coordinate Transformation Matrix” 0.6 0 0 0 0.6 0 0 0 0
I nic. Jakaś zamulona ta mysz w Linuxie, bez względu na dystrybucję.
Da się to jakoś rozwiązać? Dziękuję


(gunter) #2

Co to za mysz, jaki Linux, jakie środowisko ?
Spróbuj tak ( To set mouse acceleration and threshold ) :
xset m 2 4
lub
xset m 2 1
Czy inne , powrót do domyślnych:
xset m default

Tu więcej i jak dodać do autostartu.
https://wiki.archlinux.org/index.php/Mouse_acceleration


(pocolog) #3

Jakie środowisko? Pod XFCE czy KDE mogę sobie ustawić dowolne przyspieszenie i prędkość myszy. Wydaje mi się, że tobie właśnie o przyspieszenie chodzi. Szukaj w ustawieniach środowiska graficznego opcji od myszy.


(happypiotr) #4

W ogóle to nie działa :confused: Czy dam 2 4, czy 6 6, czy cokolwiek, czy default

Bez względu na środowisko. Czy Debian, Mint, czy openSUSE. I czy MATE, KDE i czy Cinnamon.
Myszy trzy, wszystkie Logitech. Dwie na kablu i jedna bezprzewodowa.

Ustawienia systemowe w środowisku nie działają w ogóle. Można sobie ustawiać dowolnie i nie ma efektu.

Tak po przemyśleniu, myślę że to kwestia właśnie przyspieszenia. Nie chodzi o czułość w sensie szybkości. Ogólnie chodzi mi o taki efekt, ciężko to określić, po prostu nie czuje się myszy. W Win 10 zapierniczam po wszystkim błyskawicznie jak wariat. A w Linuksie muszę jakąś uwagę skupiać na kursorze.
Coś czuję, że to może Win 10 ma po prostu jakieś własne narzędzie (rozwiązanie) co powoduje taką precyzję. Jest tam zresztą ustawieniach takie okienko do odfajkowania, zwiększające precyzję. Bo myślałem, że to jest własnie standard, a w Linuksie trzeba coś doprecyzować. No niedobrze, bo jestem bardzo uczulony na pracę myszy. Ogólnie można spokojnie sobie operować myszą, ale jak trzeba ostro przyśpieszyć w działaniach (zawodowo) to przeszkadza :frowning: a nawet wkurza.

Edit.
Może coś pokombinować z xinput.
xinput --set-prop “Logitech USB Optical Mouse” “Coordinate Transformation Matrix” 0.6 0 0 0 0.6 0 0 0 0
(aby wpisać swoją mysz, trzeba pierw zapodać xinput list)
Tylko nie mogę rozgryźć tych cyfr :confused: :confused: gdzie zamiast zera jedynkę, dwójkę, itd :slight_smile:


(Domker) #5

Mam Win10 na VM i powiem Ci, że jakoś nie widać różnicy jak przeskakuję pomiędzy Win/Linux kursorem (a w VM ustawienia myszy są niezależne).
Może kwestia sterowników grafiki ? - Masz w ogóle akcelerację 2D?


(tomms) #6

Ja sobie dawno temu do gry w CS (aby nie było żadnego przyśpieszenia/opóźnienia) ustawiłem w xorg.conf tak:

Section "InputDevice"
	Identifier "Mouse0"
	Driver     "mouse"
	Option     "Protocol" "auto"
	Option     "Device" "/dev/ums0"
	Option     "SampleRate" "1000"
	Option     "Resolution" "3000"

	# AccelerationProfile=-1 
	# no velocity-dependent pointer acceleration or deceleration. If constant deceleration
	# is also unused, motion processing is suppressed, saving some cycles.	
	Option "AccelerationProfile" "-1"

	# AccelerationScheme=none
	# disable acceleration/deceleration 
	Option "AccelerationScheme" "none"

	# upewnic sie czy tu jest dobra wartosc
	Option "AccelSpeed" "-1"


	# jesli uzywamy libinput (chyba)
	# Since libinput1.1.0-1 and xf86-input-libinput0.15.0-1 you can use a flat acceleration
	# profile which will give a 1:1 mapping of physical to virtual mouse movements
	Option "AccelProfile" "flat"

EndSection

Więcej info pod tym linkiem:
https://www.x.org/wiki/Development/Documentation/PointerAcceleration/

Aby się upewnić czy rzeczywiście wyłączyłeś akcelerację możesz użyć xinput --list-props