Czy DirectX trzeba instalować?


(sebaele) #1

Czy DirectX trzeba instalować i do czego to służy?

Dzięki


(Łukasz14) #2

DirectX – zestaw funkcji API wspomagających generowanie grafiki (dwu- i trójwymiarowej), dźwięku oraz innych zadań związanych zwykle z grami i innymi aplikacjami multimedialnymi.

http://www.dobreprogramy.pl/DirectX,Pro ... 12426.html - najnowsza wersja


(sebaele) #3

Dzięki, a czy muszę to instalować?


(Pharun) #4

DirectX jest zawsze instalowany razem z Windowsem automatycznie, ale uaktualnianie go co pewien czas jest dobrym pomysłem - wprowadzają obsługę nowszego sprzętu, zmiany wydajnościowe itd. Odpowiadając po Twojemu - LEPIEJ instalować najnowszą dostępną wersję DirectXa.


(sebaele) #5

Dzięki :-), a framefork do czego służy bo jakiś czas temu zainstalowałem wersję 2.0.


(Łukasz14) #6

Żródło: wikipedia


(Pharun) #7

Po polsku - framework jest wymagany do działania przez wiele aplikacji więc najaktualniejsza wersja też nie jest złym rozwiązaniem. Generalnie zasada jest prosta - jeżeli wychodzi aktualizacja do oprogramowania z którego korzystasz to zawsze warto ją zainstalować - zyskasz na nowych funkcjach/stabilności/szybkości/bezpieczeństwu działania danego programu.


(sebaele) #8

Dzięki, to znaczy mam odinstalować framework 2.0 i zainstalować nowszy? Jeśli tak to jaki?

Pozdrawiam


(Pharun) #9

Nic nie odinstalowuj, tylko doinstaluj najnowszy - Windows Update sam będzie znajdował najnowszą dostępną wersję i proponował instalację. W tej chwili najnowszy jest FramWork 3.5 jeżeli mnie pamięć nie myli (4.0 jeszcze chyba nie ma nie? :slight_smile: )


(sebaele) #10

Próbując zainstalować framework 3.5 wyskoczyło mi coś takiego: http://www.fotosik.pl/pokaz_obrazek/e25 ... dfee9.html

Co to znów ten Windows Installer 3.1?


(Gural7) #11

Brakuje tego http://www.microsoft.com/downloads/deta ... 776fd4138c


(sebaele) #12

A czy może być ten http://www.dobreprogramy.pl/Windows-Ins ... 11559.html?


(Erufenrito) #13

Co to jest Windows Installer: http://pl.wikipedia.org/wiki/Windows_Installer

Najnowsza wersja: http://www.microsoft.com/downloads/deta ... layLang=pl

Ogólnie rzecz biorąc może naucz się korzystać z: http://google.pl ?


(sebaele) #14

Jaki plik pobrać?

Udało mi się zainstalować Windows Installer 3.1 oraz net framework 3.5. Myślałem że framework 3.5 zastąpi framework 2.0 a tu w panelu sterowania > dodaj usuń program jest ich więcej z napisem Service Pack 1 a ja posiadam system Windows XP SP2! !!

http://www.fotosik.pl/pokaz_obrazek/d01 ... cbf43.html

I co to jest ten MSXML 6.0?


(Jacek Bydgoszcz) #15

(sebaele) #16

Oj zrobiłem sobie większy śmietnik w komputerze niż miałem :-(.


(Erufenrito) #17

A nie zauważyłeś, że ten SP1 o którym wspomniałeś jest do Framework'a ?


(Pharun) #18

Widzę człowieku że rozgarnięty w materii komputerowej to Ty wybitnie nie jesteś. Wszystko co zainstalowałeś jest potrzebne a to że pojawiły się dodatkowe wpisy w rejestrze i w opcji Dodaj/Usuń Programy jest normalne. FrameWork 2.0 to zupełnie oddzielny program od FrameWorka 3.5 i oddzielny od FrameWorka 4.0. To że masz 4.0 nie oznacza że będą działały Ci programy wymagające wersji 2.0. To tak jak by porównać NFS 1 z NFS Most Wanted - to że jedno i drugie to Need For Speed to wcale nie znaczy że to to samo.