Czy jest możliwe, żeby komputer psuł czytniki kart pamięci?


(Saeros) #1

Witajcie.

Mam dość osobliwy problem - miałem dwa czytniki kart pamięci, zewnętrzne, na USB.

Kilka dni temu jak zwykle włożyłem w jeden z nich kartę SD od aparatu i wsadziłem czytnik do portu. Zadziałał jak zwykle, lecz po chwili zniknął - program do obróbki zdjęć przestał widzieć napęd, podobnie jak Eksplorator.

Ponowne wkładanie i wyciąganie oraz zmiana portów USB (w tym z 2.0 na 3.0) poskutkowała jedynie tym, że karta raz się pojawiała jako dostępna, raz nie.

Sprzęt pada, zdarza się. Zdziwiło mnie to, że użyłem w zastępstwie drugiego czytnika i sytuacja się powtórzyła.

Trochę się przestraszyłem, bo komputer ma dokładnie dwa tygodnie (czyt. nie ma udowodnionej bezawaryjności) i pomyślałem ze zniechęceniem, że może USB na płycie jest walnięte. Aby się przekonać, wsadziłem pendrive - działa, odczyt danych z aparatu podłączonego kabelkiem - działa. Mysz przewodowa i klawiatura bezprzewodowa również działają bez zastrzeżeń.

Głupia to sytuacja, bo nie wyobrażam sobie, żeby komputer wybierał urządzenia do zepsucia, ale założyłem wątek na forum, bo już inne możliwości wykorzystałem, czyli: swój rozum, Google, test na innych komputerach oraz kolegę informatyka z pracy.

Może ktoś z Was wie o takim dziwnym przypadku?

Chciałbym kupić nowy czytnik, ale jak się okaże, że mój komp lubi je palić, to szkoda pieniążków :wink:


(Gallusik) #2

Witaj

Jeżeli podłączasz czytnik na jakimś hubie USB to podłącz bezpośrednio do wyjścia płyty głównej. Może brakować mocy. Kabel możesz mieć też zbyt długi. Nie używaj żadnych przedłużek i sprawdź w ten sposób.

Pozdrawiam

Gallusik


(Saeros) #3

Dzięki za odzew :smiley:

Przedłużek nie używam, wszystko podpinam prosto w wejście z płyty.


(Mrozek360) #4

a pod innym Pc możesz sprawdzic czy czytnik działa?


(enjoypoznan) #5

Trzeba by sprawdzić jakie jest napięcie na wyjściach USB.

Proponuje też zrobić reset bios-u do ustawień fabrycznych.

Sprawdzałeś te "uszkodzone czytniki" na innym komputerze? Jeżeli na innym również przestały działać to prawdopodobnie idzie zbyt duże napięcie na porty USB. Jeżeli czytniki nie są uszkodzone to system się obraził. Miałem podobnie z Bluetooth na USB.


(Saeros) #6

Sprawdzałem na komputerze w pracy oraz na laptopie kolegi. Pomyślałem nawet, że to może kwestia systemu, bo na tych komputerach i moim jest Windows 7, toteż wpakowałem czytnik do sprzętu z XP na pokładzie oraz Ubuntu 11.04.

Co do napięć - pomiar polega na tym, żeby "przytknąć" w USB końcówki od miernika? Czy gdzieś na płycie głównej?

Poza tym, gdyby było coś nie tak z napięciem, tak samo poszedłby mi pendrive albo aparat? Oba te urządzenia działają poprawnie.


(enjoypoznan) #7

Ja pomiar robiłem na starym kablu USB. Odciąłem końcówkę z jednej strony i do odizolowanych kabli podłączyłem miernik. Trzeba tylko uważać żeby nie zrobić zwarcia! Powinno być 5.0V , +/-0.2V

Ale z tego co piszesz to raczej kwestia programowa niż sprzętowa. Tylko skoro obydwa czytniki padły...

Może w oby tych czytnikach używasz tej samej karty pamięci i to ona poszła?

Tutaj jeszcze do poczytania: http://7pl.info/usb-specyfikacja-techniczna.html


(Saeros) #8

Karta jest w porządku – jak wspomniałem, w aparacie działa bez zarzutów; próbowałem też z innym typem kart. Taki pech widocznie.

Poczytałem Twojego linka, enjoypoznan, i myślę, że gdyby napięcie było nie takie jak trzeba byłyby problemy z aparatem, a tymczasem wszystkie funkcje działają, m.in. przesyłanie plików oraz zdalne sterowanie.

Na razie pewnie zostawię sprawę jak jest, może później pokuszę się o zabawę z miernikiem.

Dziękuję wszystkim za zainteresowanie tematem i okazaną pomoc!