Czy można łączyć formułę LUB z Wyszukaj.Pionowo w Excel?


(4dr14n) #1

Witajcie,

Moim zadaniem jest sprawdzenie, czy zawartość komórek w kolumnie A i komórek w kolumnie B znajduje się w zakresie komórek A2:F458 w innym pliku, a jeśli tak, to aby została wpisana wartość z 3 kolumny tego zakresu. Dodam, że w podanym zakresie może wystąpić wartość tylko z jednej komórki, tj. albo z komórki w kolumnie A, albo z komórki w kolumnie B.

Wykorzystałem do tego formułę Wyszukaj.Pionowo. W części, w której wpisuje się ‘szukaną wartość’, chciałem użyć formuły LUB (LUB(A48;B48)). Niestety po wpisaniu takiego zapisu wyskakuje “Błąd wartości niedostępnej”. Faktycznie w niektórych komórkach kolumny A nic nie ma, ale nwt jak coś tam jest, to dalej jest ten błąd. Dodam, że zawartość komórki B48 występuje w podanym zakresie. A w ogóle to może wystąpić tylko zawartość A48, albo zawartość B48 - nie ma możliwości, aby zawartość obydwu komórek wystąpiła w podanym przedziale.

Moja formuła wygląda tak:
=WYSZUKAJ.PIONOWO(LUB(A48|B48)|[2018.11.08.xlsx]export_rnkbs!$A$2:$F$458|3|0)

Czy ktoś mógłby mi powiedzieć gdzie popełniłem błąd?
PS: Próbowałem wpisać ORAZ zamiast LUB, ale błąd nadal widnieje.


(voxcordi) #2

“ORAZ” oznacza “i”, “LUB” oznacza “albo”… Powinieneś znaleźć pomoc w plikach pomocy formuł Exel’a.