Czy starsza dystrybucja ma sens?


(HardCore IV) #1

Witam serdecznie!

 

Microsoft Windows XP utrzymywał się wiele lat na rynku. Nawet dzisiaj jest w pewnej części wspierany przez producentów oprogramowania.

 

Niestety, posiadam już wieloletni sprzęt, jakim jest laptop HP DV6 z Radeonem HD4650 na pokładzie. Sprawa wygląda następująco:

 

Instalacja nowego systemu Linux dowolnej dystrybucji zmusza mnie do:

a) Korzystania ze sterowników wbudowanych,

b) Instalacja sterowników od AMD, które nie są kompatybilne z moją kartą graficzną

(nowe sterowniki nie są kompatybilne z GPU, a stare z systemem)

 

Mogę zainstalować np. zamiast OpenSuse 13.1, wersję 12.10 i wtedy dodać prawdziwe sterowniki od AMD bym mógł sobie pograć. Tylko pytanie czy to ma sens?

 

Czy wersje Linuxa tak bardzo się zmieniają pod wieloma względami, że warto to zrobić, czy może lepiej odpuścić sobie system Linux czekając na nowszy sprzęt?

 

Na początku dałem przykład z XP, który jest wspierany... A jak jest z Linux'em?

 

Pozdrawiam!


(stalesz) #2

Witam.

Ja pozostałbym przy XP,oczywiście z SP3.W ubiegłym tygodniu przeinstalowałem ten system,pobrał aktualizacje bezproblemowo a więc jakieś wsparcie nadal istnieje.Są problemy z IE 8 ale mamy inne browsery.Co kilka dni skan Malwarebytes Antimalware.Przynajmniej ja tak łatwo z XP nie zrezygnuję.


(aderas) #3

Nie istnieje już żadne wsparcie dla XP (jeśli chodzi o zwykłych użytkowników domowych). Pobrałeś tylko te aktualki co były, a i tak w przyszłości serwery WU dla XP zostaną wyłączone.

Autorze czy na pewno nowe stery nie działają na wszystkich nowych distro? Wymieniłeś tylko suse. A może coś z Debiano-pochodnych?


(HardCore IV) #4

To znaczy nowe sterowniki mogę zainstalować, ale nie mam po co gdyż AMD nie wspiera już w nich mojej karty graficznej. Zaś stare, które wspierają kartę, nie są kompatybilne z systemem. Spradzałem na… OpenSuse 13.1, Ubuntu 14.04, Fedora 20 oraz Mint 17.


(neXt___) #5

Potrzebne Ci do czegoś Catalysty? Być może wystarczyłyby te z repo oibafa, one nie mają problemu ze starym sprzętem.


(dragonn) #6

Otwarte stery dla AMD są już całkiem dobre, moim zdaniem dystrybucja z najnowszym jądrem + mesa powinna całkiem ładnie działać.


(Jusko) #7

Stare wersje systemu mają analogiczną sytuację co XP - nie są już zazwyczaj wspierane, niektóre z nich (pokroju Ubuntu) mają z czasem wyłączane serwery więc nic nawet nie zainstalujesz. Więc to trochę z deszczu pod rynnę - AMD/ATi po prostu nie wspiera już układów i tyle (sam doświadczyłem tego na jednym z komputerów w 2009, kiedy wrzucono niektóre układy do Legacy). Na pocieszenie - dla Windows ta firma również nie wspiera już sterowników do takich układów :wink:

 

Owszem - są użytkownicy, którzy do nowych distr wkładają stare i wspierane przez drivery kernele, Xorgi itd, ale to wkładanie starych części do nowego systemu. Pod Windows sterowniki działają, bo Windows to w zasadzie Windows, tu się dużo nie zmienia, natomiast w Linuksie nawet 6 mcy to czas na wystatczająco dużo zmian i jeśli producent nie dostosuje zamkniętych sterowników, to puff - nie działają.

 

Na stronie AMD widzę, że ostatnia wersja była 21.01.2013 roku, więc może styknie jeszcze na Ubuntu 12.04, które jest wersją LTS i ma 3 lata wsparcia  przed sobą? Znalazłbyś więcej dystrybucji na których sterowniki zadziałają, jednak nie za bardzo polecam na desktop Debiana Stable czy CentOS’a :wink:

 

Niemniej nie ma sensu się spinać i może lepiej zaprzyjaźnić się z otwartymi sterownikami - nadają się w zasadzie do wszystkiego, tylko z grami czasem nieco gorzej (choć fakt, że mój zintegrowany X1250 posłany do piachu w 2009, do dziś uzyskał może jakieś 60% jakości Catalystów na otwartych driverach - jednak wszystko się różni między układami, także warto spróbować).