Czy używa ktoś AMD Catalayst 13.4 na Radeon HD 6470M?


(ubuuser) #1

Do niedawna z powodzeniem instalowałem różne wersje sterowników od AMD w różnych dystrybucjach Linuksa i Windows. Problemy pojawiły się po wydaniu przez AMD sterownika oznaczonego numerem 13.4 - nie chce on działać w żadnej dystrybucji (z tych, które sprawdzałem). Instaluje się prawidłowo, błędów nie zgłasza, lecz na wyświetlaczu mojego laptopa niczego nie widzę tj. ciemność widzę :smiley: Mam prośbę do użytkowników Forum - czy jest ktoś, kto posiada identyczną kartę grafiki (Radeon HD 6470M) i używa sterownika AMD Catalyst 13.4? Chcę w ten sposób ustalić czy problem leży w sterowniku, czy w mojej karcie. Dystrybucja Linuksa i wersja Windows nie ma znaczenia. Proszę o pomoc.


(Qba Lukaszczyk) #2

Czy otwarte działają prawidłowo?


(ubuuser) #3

Otwarte działają. Ja jednak muszę używać zamkniętych, bo inaczej laptop mi się mocno nagrzewa.


(Qba Lukaszczyk) #4

ubuuser , komputer bootuje się i monitor w pewnym momencie "gaśnie"?


(ubuuser) #5

Zgadza się. Komputer bootuje, wyświetla logo i inne rzeczy (w zależności od dystrybucji) i tuż przed oknem logowania robi się zupełnie ciemno. W jakiejś dystrybucji (już nie pamiętam jakiej) słyszę nawet dźwięk odtwarzany w momencie dojścia do ekranu logowania, ale nic poza tym. Jest ciemno. Próbowałem ctrl-alt-Fn aby zalogować się na terminal - nie mogę, bo niczego nie widzę. Wczoraj np. zainstalowałem Manjaro 0.8.5.2 - niestety, do tego wydania już wciepielili AMD Catalyst 13.4 i nie mogę jej używać. Pobrałem więc Manjaro 0.8.5.1 i działa, bo tam jest sterownik w wersji 13.1.


(foreste) #6

Wykonaj to w konsoli

sudo aticonfig --adapter=all --initial

(Frankfurterium) #7

Próbowałeś w Manjaro instalować ręcznie wg. poleceń z Wiki?


(ubuuser) #8

@foreste i @Frankfurterium - dziękuję za zainteresowanie. Próbowałem Waszych podpowiedzi, lecz bez powodzenia. Sterowniki starsze niż 13.4 instalują się i działają bez problemu. Ten 13.4 instaluje się bez problemu, lecz nie działa. Próbowałem też na 32 bitowych dystrybucjach - to samo. Najwidoczniej mój Radeon jest uczulony na ten sterownik. Mam nadzieję, że następne po 13.4 będą działać. Ciągle liczę na to, że odezwie się ktoś, kto posiada taką samą grafikę i używa sterownika w wersji 13.4.


(foreste) #9

Musisz żyć tym problemem , bo amd/ati tak jest nić nie działa na tego ja wymieniam swojego asus eah4850 na nawet o połowę wolniejszą gainward gf 9500gt żeby niemieć problemów z sterami


(Qba Lukaszczyk) #10

ubuuser , terminal nic nie wypluwa?

Postępuj dokładnie tak jak jest opisane w tej instrukcji (odinstaluj obecne sterowniki przed instalacją):

http://wiki.cchtml.com/index.php/Ubuntu ... st.2Ffglrx


(Frankfurterium) #11

Na moim 5470 wszystko działa. I cała twoja teoria obalona.


(Qba Lukaszczyk) #12

Frankfurterium , dokładnie. Na jednym z moich komputerów (Llano APU) też wszystko OK.


(ubuuser) #13

@foreste - ja też nie zgadzam się, że nic nie działa, bo do tej pory nie miałem problemów ze sterownikami AMD. Tylko ten cholerny 13.4.

@4lpha - podany przez Ciebie przepis znam. Z reguły według niego instaluję sterownik tworząc paczki deb. Wersję 13.4 też na różne sposoby instalowałem i nic.

Dzisiaj np. zainstalowałem Manjaro 0.8.5.1 (tam jest AMD Catalyst 13.1) i działał bardzo dobrze, ale po aktualizacji (pacman -Syu) obok wielu pakietów zainstalował mi się AMD Catalyst 13.4 i po restarcie lapka ciemność widzę. Jeśli przyjdzie Wam jakiś pomysł do głowy (wymiana sprzętu nie wchodzi w grę :smiley: ) to piszcie. Pozdrawiam.


(Frankfurterium) #14

Tymczasowo możesz aktualizować system z pominięciem catalystów.

pacman -Syu --ignore [i]pakiety[/i]

albo dodać je do sekcji IgnorePkg w /etc/pacman.conf

Nie wydaje mi się, żeby wiele pakietów wymagało absolutnie najnowszej wersji sterownika graficznego.


(ubuuser) #15

O tej opcjii "--ignore" czytałem już na Wiki. Będę musiał tego spróbować. Problem jest taki, że paczek mających w nazwie "catalyst" jest kilka i z pewnością są też inne związane ze sterami do grafiki. Dzisiaj próbowałem tak: nowe paczki pobrałem do /var/cache/pacman/pkg i poleceniem pacman -U instalowałem je niemalże po kolei. Strasznie to męczące i długotrwałe, sypało błędami i po restarcie system nie wstał.


(Frankfurterium) #16

Wersję 13.4 mają jedynie pakiety catalyst-utils i lib32-catalyst-utils.


(ubuuser) #17

Dzięki. Jeszcze raz zainstaluję Manjaro 0.8.5.1 i podczas aktualizacji zaznaczę aby te dwa pakiety nie były aktualizowane.

-- Dodane 13.05.2013 (Pn) 19:23 --

Na świeżo zainstalowanym Manjaro 0.8.5.1 wykonałem polecenie

sudo pacman -Su --ignore catalyst-utils --ignore lib32-catalyst-utils

Pacman posłusznie zaktualizował system (ponad 500M danych było do pobrania). Po chwili zostałem powiadomiony, że są do pobrania brakujące pakiety językowe. Dobra, mówię, dawaj te pakiety. Okazało się, że to nie takie proste, bo dostałem kolejny komunikat: twój system jest nieaktualny, zaktuailzuj i dopiero wtedy pobierz pakiety językowe. Sprawdzam jakie czekają aktualizacje - oczywiście w/w catalyst-utils i lib32-catalyst-utils. Pomyślałem sobie, że trzeba jakoś oszukać pacmana, by "myślał", że pakiety są aktualne. Zacząłem szukać w /var/lib/pacman i zobaczyłem, że jest tam katalog local, a wnim katalogi o nazwach instalowanych pakietów wraz z numerami wersji. W przypadku w/w dwóch pozmieniałem w ich nazwach 13.1-4 na 13.4-1. Mało tego: w tych katalogach są różne pliki m.in. pliki o nazwie desc. W tych plikach, zaraz na początku jest %VERSION% i poniżej konkretna wersja. Pozmieniałem oryginalne 13.1-4 na 13.4-1. Z drżącym sercem odpaliłem pacmana, który powiadomił mnie, że mój system jest aktualny. Po kilku godzinach pojawiły się inne aktualizacje - pacman posłusznie je zainstalował :smiley: . Tak więc udało mi się pacmana oszukać i przez jakiś czas - mam nadzieję - będzie dobrze.

-- Dodane 13.08.2013 (Wt) 13:26 --

Pytanie będące tematem wątku nadal jest aktualne. Dotyczy również sterowników jeszcze nowszych tj. w wersji 13.6 albo 13.8. Zabawne jest to, że jak na wyświetlacz poświeci się latarką, albo podejdzie do jasnego okna, to coś na wyświetlaczu widać. Jest on tylko bardzo mocno przyciemniony.