Deazaktywacja usługi w systemd


(Misieksc) #1

Witam zainstalowałem sobie najnowszego Debiana 8 ze środowiskiem xfce lecz jest to komputer przeznaczony na serwer domowy i środowisko nie zawsze jest mi potrzebne i chciałbym aby przy starcie systemu nie odpalało się w ogóle i tu mam problem gdyż:


(moh3r) #2

Będąc wylogowanym z graficznej sesji (ale lightdm ma być uruchomiony), wykonaj w konsoli polecenie:

systemctl isolate multi-user.target

Jeśli lightdm zostanie wyłączony, to możesz ustawić tę zmianę na stałe poleceniem:

systemctl set-default multi-user.target

EDIT:

 

Alternatywnie spróbuj:

systemctl mask lightdm.service

“Mask” to taki silniejszy “disable” i w przeciwieństwie do “disable” działa na skryptach sysvinita.


(Misieksc) #3

Super wielkie dzięki zadziałało wszystko tak jak nalezy :wink: