Debian 6 (GNOME) - samowyłączająca się przeglądarka


(Stalmerr) #1

Witam !

Znowu mam problem.

Otóż gdy odpalam przeglądarkę na vpsie z kilkoma kartami i zostawiam ją, ona po kilku minutach sama się wyłącza. Gdy przeglądarka jest włączona vps używa maksymalnie 850 mb/1gb ram.

Czy ktoś może wie jak pozbyć się tego automatycznego wyłączania ?


#2

Już w Twoim poprzednim poście prosiłem Cię żebyś odpalił przeglądarkę z poziomu terminala. Tam wszystko będziesz miał podane.


(Stalmerr) #3

Dobra, ale jak ?

Jaką dokładnie komende mam wpisać ?

Mam zainstalowanego firefoxa jak coś.


#4

Przecież napisałem Ci to w poprzednim temacie. Odpalasz emulator terminala, wpisujesz firefox i klepiesz enter.


(Stalmerr) #5

@UP 

Prędzej nie mogłem odpalić firefoxa, bo nie miałem go zainstalowane (Nie wiedziałem jak się instaluje bez przeglądarki), a jak wpisywałem nazwę systemowej przeglądarki nic się nie działo :slight_smile:

 

http://screenshooter.net/0802611/rytqhcf

To już wszystko jasne wywala błąd out of memory...

Czy da się jakoś zrobić, by nawet gdy nie będzie ramu przeglądarka dalej działała ?


(Marcin86s) #6

Zmień środowisko na lżejsze.


(Frankfurterium) #7

 

Nie. Możesz dążyć do zredukowania zajętości RAM-u, chociaż w przypadku ciągle działającej przeglądarki i to raczej nie będzie skuteczne. Choćbyś zainstalował LXDE albo OpenBoxa, prawdopodobnie to właśnie przeglądarka będzie zajmowała najwięcej, o ile będziesz nią przeglądał "dynamiczne" strony okraszone JavaScriptem, flashem itp. Pewnym rozwiązaniem byłoby zaprzęgnięcie czysto tekstowej przeglądarki typu Lynx, ale ta prawdopodobnie jest zbyt ograniczona w możliwościach dla twoich enigmatycznych celów.


(Stalmerr) #8

Spróbuje przeinstalować vps'a na KDE, może pomoże. Mam nadzieję, że nie będzie tak jak ostatnio, iż mogłem w przeglądarce mp. normalnie wejść na gmail.com, ale nie mogłem wpisać loginu i hasła...


(Marcin86s) #9

KDE do lekkich również nie należy, jak na razie masz maszynkę do odpalania systemu i samego środowiska graficznego. Czyli marnowanie pieniędzy.

Tak z ciekawości gdzie kupiłeś tego VPS?


(Stalmerr) #10

Mintshost.pl

 

To jakie środowisko polecasz ?


(Marcin86s) #11

No nie wiem co chcesz robić więc trudno coś konkretnego polecić, ale albo wcale zrezygnować ze środowiska graficznego albo jak najlżejsze. Zobacz może XFCE, jest dość przyjazne w obsłudze, a szybsze od Gnome i KDE. Jeśli dalej będzie brakowało RAMu spróbujesz sobie czegoś jeszcze lżejszego np. LXDE, a w ostateczności TWM.


(MrQ) #12

FF z dodatkami czy bez? Wyląda na to że gdzieś pamięć cieknie, obstawiam niedopracowany dodatek, ewentualnie javę/flasha


(Stalmerr) #13

Nie instalowałem żadnych dodatków ;/

 

Zaraz zobaczę jak to będzie na innych środowiskach graficznych.


(roobal) #14

marcin86s, masz pytania niezwiązane z tematem dyskusji, porozmawiaj sobie z użytkownikiem na PW.

 

Stalmer , na początek sprawdź LXDE, ma niewielki wymagania i przy twoich zasobach powinno działać dobrze. Zamiast Firefoksa zainstaluj również coś lekkiego, np. Arora, Rekonq lub przeglądarkę tekstową Links2, która działa również w trybie graficznym i nie wymaga do wyświetlania grafiki Xserver, tak więc możesz uruchamiać ją w samej konsoli, np. przez SSH.

 

Może zamiast uruchamiać zdalny pulpit i środowisko graficzne, skorzystaj z przekierowania Xservera na host lokalny i uruchamiaj aplikacje z serwera przez SSH. Jeśli z serwerem łączysz się z Windows, będziesz potrzebował pakiet Xming (Xserver dla Windows).


(MrQ) #15

 

Rekonq


(Stalmerr) #16

No ok, ale jak np zainstalować przeglądarke Arora ?

 

Czy ten Rqkonq obsługuje java script ?


#17

A w repozytorium nie ma? Skorzystaj z apt-get, aptitude, Synaptica - czego tam używasz.


(Stalmerr) #18

http://screenshooter.net/0802611/wjiphme

 

Nie działa.

 

Z firefoxem miałem tak samo. Musiałem w sources.list wpisać "deb http://packages.linuxmint.com debian import" potem apt-get update i dopiero wtedy komenda apt-get install firefox działała. http://www.youtube.com/watch?v=PTXVJmTq-mw


#19

Jak nie ma jak jest? Coś pewnie z repozytoriami masz namieszane.


(roobal) #20

Nie, po prostu źle podał nazwę pakiety, napisał z wielkiej litery. Nazwy pakietów pisze się małą literą, chyba że nazwa pakietu jest z wielkiej to wtedy jest to wyjątek, ale nie spotkałem się w Debianie z pakietami, które mają wielkie litery w nazwie, byłoby to zwyczajnie niewygodne przy instalacji wielu pakietów.