Debian 8 - instalacja bumblebee, błąd serwera X


(DavisBond) #1

Witam. Zainstalowałem ostatnio bumblebee wraz z właściwym sterownikiem za pomocą polecenia sudo apt-get install bumblebee-nvidia primus. Zrestartowałem kompa, następnie chciałem wejść w ustawienia nvidia i wyskakuje mi takie coś http://forum.dpcdn.pl/uploads/gallery/album_876/gallery_276591_876_117123.png . Ktoś wie o co chodzi ? :) 


(dragon321) #2

Próbowałeś przeczytać ten komunikat i zrobić to, co jest na nim napisane? Wyraźnie przecież jest napisane, że nie używasz sterownika NVidia i musisz jako root wykonać komendę nvidia-xconfig, następnie zrestetować XServer.


(DavisBond) #3

Na stronie debiana pisze, że nie wolno wykonywac tego polecenia bo tyczy sie ono układ bez nvidia optimus. Warning: If you choose to install bumblebee-nvidia and the dependent nvidia driver packages, during postinst, you will see a debconf prompt warning you that you need to create a xorg.conf file in order to use the proprietary nvidia driver. This prompt only applies to non-Optimus users, i.e. single Nvidia GPU systems. Do NOT allow debconf to create a xorg.conf file, and do NOT run nvidia-xconfig! (This prompt always appears when you install nvidia packages through the repositories, and it currently does not detect Optimus/bumblebee users


(dragonn) #4
optirun nvidia-settings

Tak odpal.


(DavisBond) #5

Teraz mam coś takiego :P http://forum.dpcdn.pl/uploads/gallery/album_876/gallery_276591_876_13481.png


(funbooster) #6

Dodałeś swojego usera do grupy?

sudo adduser $USER bumblebee

(DavisBond) #7

User został juz dodany automatycznie podczas instalacji. Nadal wywala mi ten 1 komunikat…


(marcin82) #8

Dobra, podaj najpierw wynik polecenia z terminala / konsoli:

lspci -k | grep -A2 VGA

(DavisBond) #9

Jest i wynik :) http://forum.dpcdn.pl/uploads/gallery/album_876/gallery_276591_876_26284.png

Ktoś coś wie jak temu zaradzić ??


(pocolog) #10

Z tego co wyczytałem ta karta to jakaś hybryda intela i nvidia i nie jest oficjalnie wspierana przez nvidia na linuksie dlatego okno konfiguracyjne od nich nie będzie Ci działało. Widzę że rozdzielczość ekranu masz ustawioną dobrze więc sterowniki działają. Więcej raczej nic nie wykombinujesz. Możesz jeszcze wpisać “glxgears” żeby sprawdzić jak z wydajnością opengl.


(DavisBond) #11

Ahaaaa. O tym nie wiedziałem. Szkoda, że nie wspierają takich układów bo są dość powszechnie robione.  Na glxgears grafika jest na poziomie 60 fps także w porządku jak na moje parametry. Dzięki wielkie, temat zamykam :) 


(Lightextract) #12

Hmm. Na pewno jest Ci potrzebne bumblebee? Przecież jest oficjalny pakiet do przełączania układu graficznego. Jedyny warunek to przelogowanie się, aby zastosować wybrany układ graficzny. Ja mam GT 630M i Intel 3 generacji, a wszystko ładnie mi “łyka” oficjalny pakiet do przełączania grafiki. Potrzebny Ci pakiet to “nvidia-prime”, u mnie w wersji 0.6.2.