Debian, GNOME 3 - jak włączyć wygaszacz ekranu?


(Bujas Damian) #1

Witam. Jak ustawić wygaszacz ekranu w najnowszym Debianie z GNOME 3.42?


(mati75) #2
apt-get install gnome-screensaver

(Bujas Damian) #3

Potrafię sobie zainstalować wygaszacz tylko nie potrafie go włączyć. Nigdzie nie ma takiej opcji a przeszukałem całe manu. naciskam alt+ctrl+l i mam czarny obraz a chce coś ruchomego żeby mi się ekran nie psuł jak mnie nie ma przez dłuższy czas przy komputerze.


(Nythrow) #4

@GreenSpirit: Nie rozumiem. Jak to psuł? Wciskając kombinację klawiszy Ctrl+Alt+L wywołujesz polecenie blokady ekranu.

W celu zmiany ustawień wygaszacza ekranu wywołaj komendę:

gnome-screensaver-preferences

.


(Bujas Damian) #5

Od wyświetlania tego samego obrazu przez dłuższy czas psuje się monitor. Dlatego właśnie jest wygaszacz żeby obraz się zmieniał...

Blokuje się ekran i na Gnome 2 włączał się wygaszacz, a na Gnome 3 mam cały czas czarny ekran

Nie ma takiego polecenia. Mogę wpisac tylko

Instalowałem kilka wygaszaczy i żaden się nie odpala :frowning:

Szukałem w google i rozwiązania nie znalazłem. ale nie tylko ja mam problem z wygaszaczem http://forum.pclinuxos.org.pl/viewtopic.php?t=2677 instalowałem ten xscreensaver jak pisał i ten też mi się nie uruchamia.

Poratujcie panowie bo bez wygaszacza się nie obejdzie


(mati75) #6

xscreensaver dodajesz do autostartu jako polecenie:

xscreensaver -no-splash

i powinien chodzić w tle.


(Nythrow) #7

Dobrze, że masz czarny ekran, bo z tego, co się orientuję blokada ekranu polega na wygaszeniu ekranu, a nie wyświetlaniu czarnego obrazu.

Wzorowałem się na stronie domowej projektu: http://library.gnome.org/admin/system-a ... -2.html.en. Jak widać: bezskutecznie. Czy w "Podglądzie" nie masz niczego, co mógłbyś powiązać z ustawieniami wygaszacza ekranu?

Z całą pewnością jest - ostatnio instalując Ubuntu - widziałem.

Ewentualnie spróbuj doinstalować paczki:

gnome-control-center

gnome-settings-daemon

i wtedy spróbuj poszukać ustawień wygaszacza.

EDIT:

Swoją drogą. Data podanego przez Ciebie wątku jest dość... przestarzała, nie uważasz? Sugerowanie się problemem sprzed dwóch lat w tak prozaicznej sprawie raczej nie pomoże.


(Bujas Damian) #8

Mam zainstalowane te paczki a ustawień wygaszacza jak nie było tak nie ma

Ogólnie ustawień jest mało i są one ubogie. Wygląda to mniej więcej tak:

Ustawienia%20systemu_005_4f8c29b1846f9.png

Zrzut ekranu znaleziony w googlach, bo jak sam chciałem zrobić to zamiast okna był ... czarny ekran. Czarny ekran mnie prześladuje od kiedy mam G3. Ani wygaszacza ani program do screenow nie działa

W końcu pogrzebałem w dconf-editor i znalazłem pozycję "screensaver" w org-gnome-desktop i wygląda to tak

embedded-keyboard-command: -

embedded-keyboard-enabled: +

idle-activation-enabled: +

lock-delay: 1800

lock-enabled: +

logout-command: -

logout-delay: 7200

logout-enabled: +

status-message-enabled: +

user-switch-enabled: +

Czemu więc wygaszacz ekranu nie działa?

EDIT: Dodanie xscreensaver -no-splash do autostartu również nie pomogło :-x


(Nythrow) #9

Ok. Poszukałem głębiej i mocniej, ponieważ coś mi nie pasowało. Otóż... Jeśli wierzyć angielskiej Wikipedii:

Ponadto:

https://mail.gnome.org/archives/gnome-shell-list/2011-March/msg00340.html

Jeśli koniecznie chcesz mieć "rurzoffy" wygaszacz to zamiast:

gnome-screensaver

korzystaj z:

xscreensaver

(Bujas Damian) #10

No tak, tylko jak zainstaluje xscreensaver a odinstaluje gnome-screensaver to nic się nie dzieje po naciśnięciu ctrl+alt+L. Ani się ekran nie bokuje ani wygaszacz nie włacza. 0 reakcji