Debian xfce - gdzie jest synaptic?


(Jajek46) #1

Czy ktoś wie, gdzie sie podział synaptic w środowisku xfce? wyklikalem już wszystkie mozliwe opcje i nigdzie go nie widze.


(Qba Lukaszczyk) #2
aptitude install synaptic

A jeśli jest już zainstalowany, to w konsoli wpisz

synaptic

(Jajek46) #3

Zainstalowałem, ale dalej się nie uruchamia. Coś jest nie tak z tym xfce. dam screena:

rcme.png


(Jusko) #4

A co tu jest nie tak? Wciskasz klawisz q i idziesz dalej. Nie wiem jakich distr używałeś, ale albo automagicznych jak Ubuntu czy Mint, albo wcale. Debian jest nieco bardziej manulany (i fajnie), więc jeśli problem pojawia się już na starcie przez brak synaptica lub changelogu w konsoli, to jesteś pewien, że dasz radę? W gruncie rzeczy Debian nie jest tak trudny - określiłbym go jako lekką w użyciu dystrybucję nieco manualną, dlatego musisz nastawić się na to, że tu automagicznie nie wyskoczy komunikat w stylu "System do otworzenia pliku potrzebuje następujących kodeków XYZ, czy system ma je sam wyszukać i zainstalować?". Oczywiście po odpowiednim podpakowaniu systemu tak będzie, ale nie na starcie. Z XFCE jest wszystko OK zarówno w stable jak i testing - na unstable nigdy się nie rzucałem, bo kłopotów nie szukam :slight_smile:


(Jajek46) #5

Chyba faktycznie sobie podaruje tego debiana, bo podczas instalacji od paru dni nie moze sie też polaczyc z repozytoriami (wszystkimi, nie tylko security)

debhp.png

Niech nikt nie mówi, że to takie stabilne distro.


(Jusko) #6

Podczas instalacji są czasem kwiatki (ale tylko czasem, niedawno np. w iso testinga zamiast literek w instalatorze były kwadraciki, no ale to TESTING). Dlatego wpierw zainstaluj, potem aktualizuj. Ja próbowałem przed chwilą i muszę rzucić słynny tekst: "u mnie działa" :slight_smile: Od zawsze mówiło się, że Debian jest dla rozgarniętego już użytkownika Linuksa, dla początkującego też się nada, ale już na starcie będzie musiał nauczyć się paru rzeczy - debek nie jest adresowany do tych samych użytkowników co Ubuntu lub Mint. Debian jest stabilny w wersji Stable - jak ktoś używa Testing lub Unstable (Sid), to nie ma się co dziwić, że czasem może się coś sypnąć - nazwy mówią same za siebie. Ja nigdy nie używam sieci do instalacji, bo i po co (zresztą instalator obsługuje chyba bezpośrednie połączenie DHCP tylko, PPPoE już odpada przykładowo). Zainstaluj normalnie, doklej repozytoria od odpowiedniego wydania, potem dopiero aktualizuj i instaluj co chcesz: http://debian.linux.pl/threads/1408-Repozytoria-Debiana-wpisy-w-pliku-etc-apt-sources-list. Debian wymaga zwyczajnie nieco bardziej manualnego podejścia, nie za dużo, ale jednak, a jak wspomniałem - stabilny jest Stable (obecnie Squeeze), natomiast w Testing czy Unstable mogą już być niespodzianki - niekoniecznie, ale jednak, wydania testowe czy niestabilne, nie ma czemu się dziwić. Niemniej Testinga można śmiało brać na desktop i aktualizować tak raz na tydzień czy dwa (tak robię ja, aby w przypadku poprawki coś psującej, zdążyli wydać łatkę tej łatki) :wink:


(marcin82) #7

jajek46

Podaj wyniki takich poleceń (#):

lsb_release -a && uname -r

apt-cache policy synaptic

cat /etc/apt/sources.list

cat /etc/apt/preferences

ls -afull /etc/apt/sources.list.d

(Jajek46) #8

@Jusko z chęcią bym wgrał stable, bo te nowe gnome w testingu mi nie odpowiada, ale stable ma przestarzały soft. Dlatego postanowiłem spróbować xfce chociaz juz wolalem gnome2.

@marcin'82 http://wklej.org/id/643492


(Qba Lukaszczyk) #9

Może wypróbuj zatem LMDE?

Jeśli nie możesz sprostać Debianowi.


(marcin82) #10

jajek46

Wstaw dokładne wyniki komend nr 3 i nr 5, o które pytałem. Narazie wiem tyle, że prawdopodobnie zainstalowałeś Debiana Squeeze (wydanie stabilne), a repozytoria masz z wersji Sid (Unstable), albo nieumiejętnie mieszasz wydania (brak pliku /etc/apt/preferences) ... W ten sposób niedługo rozwalisz system. Tym bardziej, że Synaptic jest jak najbardziej dostępny dla wydania Squeeze (powinien być widoczny w wynikach polecenia apt-cache policy synaptic: http://packages.debian.org/squeeze/synaptic .

Poprawne adresy repozytoriów dla danego wydania Debiana znajdziesz tutaj:

http://debian.linux.pl/threads/1408-Rep ... urces-list . Pokaż listę repozytoriów albo popraw samodzielnie. Wracając jednak do sedna ;]

Menu (programów Xfce) => System => Synaptic Menedżer Pakietów.


(Jajek46) #11

Wstawiłem dokładnie wszystkie komendy. A z tego adresu co podales wlasnie wzialem te repo. Po swiezej instalacji system nie posiadal synaptica, musialem go dopiero doinstalowac. Obecnie mam repo z sida, czytalem ze nie jest taki zly:

#~Sid~#

deb ftp://ftp.pl.debian.org/debian/ sid main non-free contrib

deb-src ftp://ftp.pl.debian.org/debian/ sid main non-free contrib

(Jusko) #12

Stable jest dlatego właśnie stabilny i na tym polega jego zasada - pakiety są przestarzałe, jednak przetestowane wszystko na lewo i prawo. Stąd na serwer OK, ale na desktop - jak kto woli (ja choćbym chciał to nie mogę, bo mam kartę ATi w stacjonarce i lapku, więc na bieżąco chcę być ze sterownikami otwartymi). Na podobnej zasadzie działa Ubuntu wydania LTS - po pewnym czasie pakiety są zamrażane, nowe wersje programów są już rzadkością, ale system masz często skałę (z LTS Ubuntu testowałem tylko 2 lata 8.04 i skałą to on był - ostatnie solidne wydanie). Testowe i niestabilne wydania mogą sprawiać już pewne niespodzianki. Na desktop moim zdaniem najlepszy jest Debian Testing - jest on pośrednim stanem między Unstable a Stable. Pakiety które w Unstable nie sprawiały problemów, trafiają do Testing a po działaniu na medal i załataniu systemu - mamy kolejne wydanie stabilne.

Wnioskuję z tego co napisałeś, że masz Debiana Stable a repo z Sid'a...zła zasada, będą kłopoty po jakimś czasie albo i od razu. Ze stabla zaktualizuj do sid distro (jeśli sida chcesz), potem dopiero instaluj soft nowy. Wprawdzie siłą rzeczy byś zaktualizował, bo kiedyś wklepałbyś aptitude full-upgrade, no ale...


(Jajek46) #13

Gdyby była taka możliwość, to bym od razu zainstalował sida, ale w wersji z xfce nawet w zaawansowanym instalatorze nie było takiej opcji.


(Jusko) #14

Dlatego instalujesz takie wydanie jak masz. Po uruchomieniu aktualizujesz je, aby wszystko było aktualne na tip top. Następnie z pliku /etc/apt/sources.list usuwasz obecne repa i wklejasz adresy rep z wydania, do którego chcesz aktualizować. Teraz wchodzisz w terminal, wydajesz polecenie aptitude dist-upgrade, po czym aktualizuje Ci się system do wersji, jaką chcesz. Instalator Testinga wciąż ma dla mnie pewne błędy (a może już nie ma, nie sprawdzałem, stawiam system raz i działa :slight_smile: ), dlatego to jest metoda, jaką zawsze to robię (instalacja Stable-->aktualizacja-->Testing).


(Jajek46) #15

Łatwiej chyba z bussinescard wybrać podczas zaawansowanej instalacji od razu testinga.


(Jusko) #16

Jasne że łatwiej, ale ja łączę się z siecią poprzez PPPoE, którego instalator chyba nie obsługuje, chyba że coś przeoczyłem. Trzeba mieć też w miarę fajne łącze, aby dociągnąć system :slight_smile: Łatwiej dla mnie jest taką metodą :slight_smile: