Dell Venue 11 Pro nie działa wifi Atheros na Ubuntu 14.10


(Zuberator) #1

Witam.

Mam tablet Dell Venue 11 Pro 7130 z procesorem i3-4020y i kartą sieciową atheros- Dell Wireless 1537.

System w ogóle nie wykrywa karty, próbowałem sposobów z kilku for, gdzie ludzie mieli podobny problem, ale nie potrafię uruchomić karty.

Zrobiłem według instrukcji stąd: http://ubuntuforums.org/showthread.php?t=2187204&page=9

Ale nie wiem jak edytować plik sdio.c, nie mogę go znaleźć.

Proszę o pomoc.


(Lightextract) #2

Co prawda niby testowa wersja systemu, ale spróbuj może zainstalować Ubuntu 15.04? Potem stopniowo sam zaktualizuje sobie pakiety do stabilnych, jak takie wyjdą. Może tam zadziała Twoja karta? Chociaż to i tak dla mnie dziwne… mnie na każdym laptopie wszystko chodziło dobrze, jeżeli chodzi o wifi.


(Zuberator) #3

Z tą kartą jest taki problem, że Dell udostępnia sterowniki tylko na Windows 8.1 i nawet z Windowsem 10 musiałem kombinować, żeby ją uruchomić. I pierwszy raz mi się zdarzyło, żeby karta nie działa natywnie na sterownikach wbudowanych w Windows, tylko trzeba specjalnie ściągać ze strony dell-a.

Na Ubuntu 15.04 też nie działa. Wiem, że są duże problemy ze sterownikami do tej karty, ale niektórym podobno działa, więc da się…


(pocolog) #4

Sprawdź czy masz załadowany moduł atheosa

lsmod | grep ath9k

(hnxhsnhdc) #5

Upewnij się, że używana karta nie jest uszkodzona. Pamiętaj też, że wersja karty powinna być zgodna z urządzeniem firmy Dell. Również sterowniki karty wifi nie powinny być uszkodzone. Musisz używać zaktualizowanych sterowników WiFi i nowych wersji sterowników. Proste uruchomienie może rozwiązać ten problem. Jeśli nic z tych wszystkich nie działa, sprawdź dokumentację Dell Venue 11 Pro Manual i postępuj zgodnie z tym, co mówią eksperci.