Dev-C++ nie działa


(Jedras121) #1

Witam.

Chciałem dzisiaj coś porobić w dev-c++, ale niestety program nie zadziałał. Wyświetlił się komunikat "Plik źródłowy nie jest skomplikowany".

Najpierw przejrzałem kod czy nie ma jakiś błędów, ale wszystko wydawało się ok. Spróbowałem więc skompilować program w Visual 2010 beta2. Wyświetlił się podobny komunikat.

Spróbowałem skompilować najprostszy program jaki mi przyszedł do głowy, ale nic się nie zmieniło. Reinstalacja Dev'a też nie pomogła. Oto kod najprostszego programu:

#include 

using namespace std;


int main()

{

    cout<<"działa";

    system("PAUSE");

    return 0;

}

Pomóźcie.


(Kstarski) #2

czy na pewno zapisujesz jako *.cpp ?

głupie pytanie, ale kiedyś nie mogłem czegoś skompilować bo zapisałem program C++ jako *.c :lol: :stuck_out_tongue:


(Jedras121) #3

Oczywiście, że zapisałem jako .cpp


(Kstarski) #4

to niestety nie mam pojęcia czemu nie działa DEV, jeśli masz chęć sprawdzić inne IDE to polecam CodeBlocks (http://www.codeblocks.org/downloads/binaries#windows)

sciagnij tą cieższą wersje z kompilatorem, jeśli tutaj też nie zadziała to rozkładam ręce :slight_smile:


(Jedras121) #5

No ten link co podałeś coś chwilowo nie działa, ale ciągne stąd http://www.dobreprogramy.pl/CodeBlocks-Studio,Program,Windows,12197.html Mam nadzieję, że o to chodziło.

-- Dodane 22.11.2009 (N) 15:23 --

Też nie skompilowało, ale za to dostałem wiadomość

mingw32-g++.exe: installation problem, cannot exec `cc1plus': No such file or directory

(system) #6

Dev-Cpp ma problemy pod windows'ami 64-bitowymi.

a właściwie nie działa tylko make.exe (od mingw)


(Jedras121) #7

Po pierwsze siedzę na widowsie 32-bit i dotychczas nie było żadnych problemów. Dopiero dzisiaj.


(Kstarski) #8

bo na DP jest wersja bez kompilatora (10MB), z kompilatorem zajmuje 19MB

masz tutaj wersje z kompilatorem (MinGW):

http://downloads.sourceforge.net/codebl ... -setup.exe

lub

http://prdownload.berlios.de/codeblocks ... -setup.exe


(Jedras121) #9

a pozatym skoro również visual i podany powyżej CodeBlocks też nie działają to chyba bardziej wina systemu niż kompilatora

-- Dodane 22.11.2009 (N) 15:48 --

O dzięki kstarski. Może teraz zadziała.


(Kstarski) #10

na win7 x64 kompilator MinGW działa jak trzeba.


(Jedras121) #11

Przecież to się można załamać. CodeBlocks z MinGW też nie działa :frowning: . Też dostaję ten komunikat

mingw32-g++.exe: installation problem, cannot exec `cc1plus': No such file or directory

:?


(Kstarski) #12

dziwne, wygląda na to ze mingw nie dopisało się do zmiennych środowiskowych, spróbuj ręcznie, przejrzyj linki:

http://zieaon.co.uk/MinGW-cc1plus.html

http://wiki.codeblocks.org/index.php?ti ... with_Vista

a może masz viste bez service pack?


(system) #13

Nie mówiłem że nie działa kompilator, tylko Dev-Cpp i nie z powodu nie działania kompilatora, tylko z powodu nie działania make.exe

* Na Win7 x64 nie sprawdzałem.


(Jedras121) #14

Hej. Sorry, że nie pisałem. Tak więc dev-c++ i codeblocks niestety nie działają, ale visual po reinstalacji zadziałał. Obawiam się, że jakieś pliki systemowe zostały naruszone więc czeka mnie reinstalacja systemu. Ale i tak już się miałem przesiąść na 7. Mam nadzieje że po tym wszystko wróci do normy. dzięki za pomoc :smiley:


(U Nic0rn) #15

Dev C++ juz zdechl. Nikt na tym projektu juz nie pracuje.

Visual C++ to jest najlepsze na rynku.