Dodatkowy dysk na USB i opóźniony start Windows XP


(bachus) #1

Witam.

Sytuacja następująca:

  • OS: Windows XP SP3 Prof

  • dysk twardy podłączony przez USB

W czasie, gdy dysk jest podłączony do USB system wstaje o około minutę dłużej - "zawieszenie" botowania następuje już po odczytaniu MBR, przejściu przez boot menu, przed rozpoczęciem wczytywania Windows XP (w przypadku włączania systemu z hibernacji jest to przed samym rozpoczęciem pojawiania się paska postępu wczytywania obrazu pamięci z HDD). W czasie, jak jest to "zamrożenie" można odpiąć dysk USB, wtedy rozpoczyna się poprawny start.

  • dysk na USB nie ma systemu operacyjnego, nigdy nie miał, nie miał

  • system plików NTFS

  • w boot menu nie ma nic związanego z innymi napędami, tylko związane z dyskiem twardym w laptopie

Nie wiem, jak usunąć problem, nie chcę za każdym razem odpinać dysku USB (laptop służy jako stacjonarny). Czy to jest jakiś problem związany z szukaniem systemu na dysku USB, czy z jakimiś sterownikami?

p.s. podłączenie np. pendrive nie skutkuje podobnym problemem.


(Jimek) #2

A jakiej pojemności jest dysk?


(bachus) #3

500GB, jedna partycja podstawowa NTFS, nie było na dysku nigdy systemu operacyjnego (poza obrazami ISO :wink: )


(Jimek) #4

Mam kolegę który tez pod laptopa podłącza dodatkowy HDD przez USB, ale włącza go właśnie dopiero po zalogowaniu do systemu. Inaczej system strasznie długo się ładuje.

Więc, według mnie to przez rozmiar. Przy "pendraku" się tak nie dzieje bo to pamięć flash z wystarczająco szybkim dostępem do pamięci, a HDD ma kilkanaście (jeżeli nie kilkadziesiąt) razy większy czas dostępu do pamięci. Więc jak przy pamięci flash zajmuje to sekundę, to dla HDD analogicznie kilkanaście (kilkadziesiąt) sekund.


(bachus) #5

Nie te czasy, jak dostęp do dysku HDD to kilkanaście sekund...


(Jimek) #6

No rzeczywiście, przesadziłem. Co nadal nie zmienia faktu że to obstawiam.

W szczególności że tak jak już pisałem u mojego znajomego jest identycznie na różnych kompilacjach XP'eka.