Domyślna rozdzielczość


(Rosiak112) #1

Mam linuxa opartego na debianie, i mam pytanko, jak ustawić standardową rozdzielczość podczas uruchamiania środowiska graf ?

Bo standardowo uruchamia mi się z rozdzielczością 1280x960 jednak moja karta graficzna nie obsługuje takiej rozdzielczości przez co kursorem myszki moge poruszac do polowy ekranu, a klika sie w innym miejscu, po przestawieniu na 1026x860 wszystko ok, ale za każdym razem ustawianie rodzielczości z kursorem który się klika kilkanascie cm dalej to problem.

Nie wiem czy to ma znaczenie ale to gnome, ale na fluxbox mam to samo.


(ra-v) #2

Spróbuj w opcjach jądra dopisać/zamienić (przy starcie jest taka linijka do wpisania jakiegoś tekstu, być możę musisz wcisnąć B) vga=0x314 lub vga=0x317

Poza tym zrób kopię /etc/X11/xorg.conf i dopisz/zamień sekcję poniżej zamieniając odpowiednie rozdzielczości.

Pierwsza w linii <> jest zawsze tą domyślną, z którą odpala się logowanie.

Section "Screen"

    Identifier "Screen0"

    Device "Device0"

    Monitor "Monitor0"

    DefaultDepth 24

    # Option "AddARGBGLXVisuals" "True"

    SubSection "Display"

        Depth 16

        Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

    EndSubSection

    SubSection "Display"

        Depth 24

        Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

    EndSubSection

EndSection

(Rosiak112) #3

Nie mam czego robić kopi bo nie mam xorg.conf

Utworzyłem xorg.conf i dałem wpis co mi podrzuciłeś i działa jak należy.

Wielkie Dzięki :wink:


(Kaka') #4

rosiak112 ,

Rejestrując się na niniejszym forum zobowiązałeś się przestrzegać jego regulaminu. Niestety, w tym momencie łamiesz go nie tytułując poprawnie tematu. Proszę zapoznać się w pierwszej kolejności z regulaminem forum, a następnie z tym tematem. Po zapoznaniu się proszę poprawić tytuł tematu, używając przycisku zmien.gif