Drukarka hp photosmart c3180 niewykrywana przez windows7


(Belka153) #1

Witam, niedawno zakupilem windows 7, wszystko dziala oprócz drukarki hp photosmart C3180.Otóż po podłaczeniu wyskakuje tylko "nieznane urządzenie" a w menedżer zadan "uknknow device. Sterowniki z płyty niestety nie są obsługiwane przez win7 dlatego ściągnąłem te : [](%7Boption%7D)http://h10025.www1.hp.com/ewfrf/wc/soft ... 46331#N193[url/] . po instalacji wymagane jest wlaczenie i podlaczenie urządzenia aby dodac nowe urządzenie, jednak przycisk "dalej" zostaje szary i nadal urządzenie jest nieznane. W panelu sterowania w opcji dodania drukarki nie ma tego modelu wiec nie wiem co można jeszcze zrobić. Wyczytałem na niektorych forach ze drukarka ta nie jest obslugiwana przez win 7 w co nie wierze gdyz nie jest to jakis stary model.

Z góry dziekuje za pomoc.

edit:Przepraszam za pomyłke, moj model to photosmart c3180 a nie c3190


(dark__jedi) #2

Próbuj ze sterownikami z Visty.

Być może taki pakiet pomoże..


(Belka153) #3

Niestety nie idzie tego pobrać. Po uruchomieniu instalatora zaczyna się pobieranie i po pobraniu ok 1mb pasek stanu i przyciski znikaja po czym program sie zawiesza.


(dark__jedi) #4

Sprawdziłem, mi też nie pobiera.

Odinstaluj wszystko w trybie awaryjnym i spróbuj tej drogi

http://h10025.www1.hp.com/ewfrf/wc/soft ... p-113584-1


(Belka153) #5

Ten sam problem, kreator instalacji drukarki wymaga wlaczenia i podlaczenia urzadzenia, po zrobieniu tego wyskakuje w prawym dolnym rogu " uknown device" a przycisk "dalej" w kreatorze wciąz niedostępny


(dark__jedi) #6

Na tą chwilę co przychodzi mi na myśl, to sprawdzenie drukarki na innym systemie Windows7. Weź gdzieś drukarkę i sprawdź czy występuje problem.

Warto też sprawdzić na innym systemie np Vista, XP, żeby potwierdzić winę samego oprogramowania lub/i Windowsa7.


(Dimatheus) #7

Hej,

A próbowałeś nieco inaczej dodać drukarkę przez aplet Dodaj drukarkę - zamiast wybierać ją z list, klikasz przycisk Z dysku i wskazujesz folder, do którego wypakowujesz ściągnięte sterowniki. Jeśli są w formacie pliku exe, najlepiej wypakować je przy pomocy programu WinRAR bądź 7-Zip.

22738108567004104364_thumb.jpg

Pozdrawiam,

Dimatheus


(Belka153) #8

Po zrobieniu tak jak Dimatheus polecił, po wybraniu foldery wyskoczyło okienko

"Określony folder nie zawiera zgodnego oprogramowania sterownika dla urządzenia. Jeśli folder zawiera sterownik, upewnij się, że sterownik jest przeznaczony dla urządzenia System Windows dla systemów opartych na procesorze x64"

Co do rady dark_jedi , drukarka działała bez zarzutów na systemie Windows Xp i ubuntu,

na windows 7 postaram sie sprawdzic jak najszybciej, narazie nie mam takiej mozliwosci.


(Dimatheus) #9

Hej,

:arrow: Wypakowałeś zawartość pliku do folderu, który wskazałeś?

:arrow: Zaznaczyłeś, by instalator sprawdzał też podfoldery? Wskazałeś główny z folderów, w którym wypakowałeś sterowniki?

:arrow: Czy instalowałeś system Windows 7 na czysto, czy dokonywałeś aktualizacji z poziomu systemu Vista? Jeśli z poziomu Visty, spróbuj tego.

:arrow: Próbowałeś podłączać drukarkę do innych portów USB?

Pozdrawiam,

Dimatheus


#10

zyx106 , proszę zapoznaj się z tą stroną oraz tym tematem, a następnie, używając przycisku image.php?album_id=20&image_id=4038


(Belka153) #11

Hej,

Wypakowałem pliki do wskazanego pozniej folderu, nie znalazłem opcji sprawdzania podfolderów. System windows swiezo kupiony, instalowany na nowy komputer. Próbowałem wszystkie porty USB, dzisiaj spróbuje na laptopie z windows 7.


(Dimatheus) #12

Hej,

Racja. Zaznaczyć coś takiego można jedynie w przypadku aktualizacji sterowników z poziomu na przykład menadżera urządzeń. I może właśnie jest to trop. Piszesz, że drukarka jest widoczna jako nieznane urządzenie. Wejdź zatem do menadżera urządzeń i klikając na nieznane urządzenie wybierz z menu kontekstowego polecenie aktualizacji sterownika. Oczywiście wybierz ręcznie folder, o którego wypakowałeś sterowniki i zaznacz opcję przeszukiwania podfolderów. Jakikolwiek efekt?

System zawiera dodatek Service Pack 1?

Daj znać, jakie rezultaty.

Pozdrawiam,

Dimatheus


(Belka153) #13

Troche dziwna sprawa bo po około 1 sek przeszukiwanie folderu zakonczylo sie i pisało:

"System Windows ustalił, że oprogramowanie sterownika dla tego urządzenia jest aktualne.

-Uknown Device "

System zawiera service pack 1 a na laptopie identyczna sytuacja. Słyszałem że kiedyś, w latach 90tych aby dodać urządzenie trzeba było wpisać co to za urządzenie i gdzie jest podłączone, jest to w dzisiejszych czasach też możliwe?


(Dimatheus) #14

Hej,

Faktycznie, mocne... Sterownik do nieznanego urządzenia jest aktualny.

Po części tak. Dzisiaj można zrobić podobnie, wybierając właśnie w kreatorze opcję dodania drukarki. Można zdefiniować bądź dodać nowy port. Ale by dodać ostatecznie drukarkę, urządzenie musi być w systemie wykrywane jako drukarka, a nie jako sprzęt niezidentyfikowany.

:arrow: Próbowałeś podłączyć drukarkę innym kablem USB? Może ten akurat jest uszkodzony.

Pozdrawiam,

Dimatheus


(Belka153) #15

Kabel raczej sprawny bo działała wcześniej bez zarzutów, nagram jeszcze może ubuntu i tam sprawdze czy dziala, bo o ile pamietam tam nie byly potrzebne zadne sterowniki.

Ewentualnie jak sie skonczą pomysły to zostane przy 2 systemach, jednak nie bedzie to w 100% komfortowe. Troche dziwna sprawa że występuje taki problem przy nie tak starym urządzeniu.

Mimo to dziękuje za fatygę, mogę jeszcze zanieść kompa i drukarke do pewnego sklepu, w ktorym zapewniano mnie ze to jest mozliwe do zrobienia i moga to zrobic, tylko ze nie dosc ze nie bede mial sprzetu przez ok. dzien to jeszcze zaplacic bede musiał ;/


(Dimatheus) #16

Hej,

Masz rację - ale jeśli się uszkodził, to teraz może działać niepoprawnie. Warto mimo wszystko to sprawdzić.

Tym bardziej, że pojawia się komunikat o nieznanym urządzeniu. Gdyby były to problemy ze sterownikami, urządzenie i tak powinno być wykryte jako drukarka.

Tym bardziej warto by sprawdzić inne pomysły - na przykład ten z innym kablem USB.

Pozdrawiam,

Dimatheus


(Belka153) #17

Problem rozwiązany, jednak kabel stwarzał usterkę lecz nie dlatego że był popsuty lecz zły.

Chodziło o to ze kabel obsługiwał za słabe napięcie czy coś takiego, (dałem do serwisu więc nie jestem w pełni wtajemniczony)

Teraz śmiga bez problemu. Dziekuję za rady :smiley:


(Dimatheus) #18

Hej,

Czyli jednak trop był słuszny. :slight_smile:

Z ciekawości - jakiej długości był kabel, którym pierwotnie podłączałeś drukarkę i skąd pochodził? Był dołączony do drukarki czy kupiony osobno? I jakiej długości jest obecny kabel, ten przy którym wszystko działa poprawnie?

Pozdrawiam,

Dimatheus


(Belka153) #19

Kabel był oryginalnie dołączony do drukarki, miał długość ok. 2m, ten nowy ma ta sama dlugość, jedyna roznica to o ile pamietam w napisie na kablu w nowym było 28a a w starym tego brakowalo.


(Dimatheus) #20

Hej,

Generalnie dodatkowe opisy na kablach to - z leksza mówiąc - ściema. Pewnie przez to w serwisie dodatkowo Cię skasowali wmawiając, że kabelek jest lepszy. A prawda pewnie jest taka, że kabel był uszkodzony. Nie sądzę, że kabel dołączony do drukarki mógł być tak fatalnej jakości, by tłumił sygnały elektryczne tak mocno, że prawidłowe wykrycie drukarki było niemożliwe. W końcu sam pisałeś, że na początku wszystko działało poprawnie...

Pozdrawiam,

Dimatheus