Drukowanie pod ubuntu 7.10


(Monczkin) #1

Witam.

System wykrywa prawidłowo drukarkę, hp deskjet 710c, instaluje strerowniki. Teoretycznie wszystko jest w porządku. Niestety nie można niczego wydrukować. Zadanie druku wisi... i cisza.


(matiit) #2

A drukarka kiedykolwiek działała pod linuksem?

SPrawdź co się dzieje w localhost:631 (w przeglądarce jako adres to wpisz) szczególnie sprawdź zakładki wydeuki i drukarki)


(Monczkin) #3

Tak. W poprzedniej wersji drukowała bez problemu.

A co dokładnie ??

W zakładce printers jest

a w jobs


(matiit) #4

:confused:

spróbuj ręcznie podać plik ppd

Btw dużo osób ma problemy z tą wersją 7.10 (np. dziś kolega pisał że nie działa mu odtwarzacz mp3 przez usb)


(Monczkin) #5

Niestety, nic nie dało.

Zainstalowałem Debiana i to samo. Odnoszę niejasne wrażenie, że to może coś z jądrem lub innym pakietem odpowiedzialnym za serwer druku ??


(matiit) #6

U mnie arch nie drukuje w ogóle... (drukarka HP deskjet d2360), Gentoo radzi sobie świetnie.

IMO to arch ma coś skopane z pakietem hplip (może Debian i ubuntu też, jakiś źle skompilowany pakiet)

spróbuj starszą wersję hplipa


(Monczkin) #7

jakieś wskazówki :slight_smile:

BTW. Podoba mi się Linux, ale ilość potencjalnych problemów jest koszmarna. Próbowałem Mandrake'a, Fedorę, Auroxa, Ubuntu, Debiana i zawsze coś, qrcze jest nie tak :stuck_out_tongue: OS po zainstalowaniu powinien hulać aż miło, a ty koszmar z podstawami... No chyba, że ja mam pecha. Ale nei rezygnuję :stuck_out_tongue:


(matiit) #8

no nie wiem jak tam w Debianie się starsze wersję instaluje...

aptitude install hplip-jakaś-wersja

najlepiej tak ze 2-3 numerki do tyłu (jak jeszcze był daemon do tego.)

i jak sie zainstaluje to zanim chcesz coś wydrukować dajesz /etc/init.d/hplip start (z roota)

zaraz poszukam wersji która jest jeszcze jako daemon

http://packages.debian.org/etch/hplip

Złączono Posta : 03.11.2007 (Sob) 10:44

Nie było mi bardzo potrzebne rozwiązanie bo drukowałem na gentoo..

Ale teraz poszukałem głębiej i już mi działa na archu.

W archu problemem byłą regułka udeva.

Dawał drukarce złe uprawnienia.

Trzeba je zmienić na 666 poleceniem chmod

Jak?

lsusb

jednym z urządzeń będzie drukarka

będzie miała jakiś identyfikator u mnie było to:

Bus [b]002[/b] Device [b]002[/b]: ID 03f0:c302 Hewlett-Packard

czyli drukarka jest w /dev/bus/usb/002/002 Więc polecenie

sudo chmod 666 /dev/bus/usb/002/002

u mnie załatwiło sprawę.

Raczej po reboocie nie będzie działać...

na razie dodałem to do rc.local :slight_smile: ale można to pewnie zrobić edytując regułkę udeva.

Niestety nie wiem czy to w ubuntu pomoże. Jesli też problemem jest zła regułka udeva to pomoże :slight_smile:


(JarekMk) #9

A jakie środowisko ? Gnome, KDE czy inne ?


(Monczkin) #10

Gnome


(matiit) #11

Monczkin

Twoja drukarka jest na usb?


(Monczkin) #12

LTP.

Jak wspominałem, w poprzedniej wersji Ubuntu, wszystko bangla.

Odnoszę wrażenie, ze to albo jąderko albo serwery druku są skopane.


(matiit) #13

Też t myślałem że to wina hplip u siebie a jednak problemem były uprawnienia.

U Ciebie najprawdopodobniej drukarka jest w /dev/parport0

Możesz zobaczyć jakie masz uprawnienia.

polecenie

ls -all /dev/parport0

możesz próbowac zmienić je na 666

chmod 666 /dev/parport0

i sprawdzić czy drukuje.


(Monczkin) #14

Ok. Dzięki. wieczorem w domu sprawdzę. (teraz jestem w pracy)


(matiit) #15

to sprawdź jeszcze to:

sudo aa-complain cupsd

na debianie bez sudo, tylko z roota... Choć tą poradę znalazłem na bugzilli UBUNTU

https://bugs.launchpad.net/ubuntu/+bug/133982