Dwa problemy z postawieniem serwera gry (port oraz instalacja)


(Mcartick) #1

Witam,

z kolegami chcemy pograć w pewną grę przez neta, jednak tylko ja mam możliwość stawiania gier (to się nazywa IP zewnętrzne czy coś takiego). Pierwszym problemem było to, że mam zajęty port 80 (kiedyś bawiłem się w stawianie serwerów www i podejrzewam, że jakiś apache albo coś podobnego może ciągle działać w tle, jednak mimo to, że wszystko co tylko przyszło mi do głowy odinstalowałem port nadal wydaje się być zajęty, a serwer z przyczyn mi nie znanych koniecznie chce użyć do czegoś tego portu i wywala błąd przy próbie uruchomienia), w jaki sposób mogę "namierzyć" program który wykorzystuje ten port?

 

Drugi problem jest w tym, że chciałem spróbować odinstalować i zainstalować program do stawiania serwera, jednak podczas odinstalowywania pojawił się błąd, ale mimo to wszystko przyszło do końca, folder z serwerem zniknął z program files itp, jednak przy próbie nowej instalacji pojawia się komunikat że program jest zainstalowany, a po kliknięciu, że chcę go odinstalować wywala błąd, że program nie możne odnaleźć ścieżki D:/Program Files (x86)\Game Serwer\uninstall.exe . Co mogę z tym fantem zrobic?

Z góry dzięki i pozdrawiam. :wink:


(fiesta) #2

 

http://www.webzky.pl/projektowanie-stron/zwolnienie-portu-80/

 

Tu   coś   gostek   sepleni::

 

http://www.youtube.com/watch?v=A6UTjxDYPWQ

 

Ale   ogólnie  chodzi o  to  aby ubić proces Apache.


(Mcartick) #3

znalazłem proces który zajmuje port, mam linijkę:

 

TCP [::]:80 Sielly-asusn61v:0 NASŁUCHIWANIE 4

 

po odpaleniu alt ctrl del i zrobieniu tak jak tam jest napisane okazuje się że port wykorzystuje aplikacja “System” (opis NT Kernel & System), która nie chce dać się zabić. Jakieś propozycje co z nią zrobić?


(fiesta) #4

 

Tylko   tak  się  składa  że ona  nie  zajmuje  portu tylko nasłuchuje  na  nim i ubicie  tego  procesu  nie  zwolni  portu.


(Mcartick) #5

W liście nic nie widzę (nic innego) z portem 80. po wejściu na 127.0.0.1:80 wyskakuje biała strona (brak treści, bez żadnego kodu źródłowego, nie ma #404 not found ani nic).Do tego po odłączeniu Internetu problem jest taki sam.