Elementy wyświetlają się na Firefoxie a na IE 8 nie


(Karassu) #1

Witam, mam problem. Przerabiam template pod swoje potrzeby i mam problem z niektórymi elementami. Mianowicie bardzo dużo elementów wyświetla się na firefoxie, chromie itd, a ta IE 8 nie. Jakiś pomysł na rozwiązanie problemu ?


(MrBeckham666) #2

w sumie IE nie jest już rozwijany wiec nie dziwie się że są problemy.


(stalesz) #3

O który OS Ci chodzi ? Na Win7 i pochodnych jest wersja 11.Masz XP..?


(Karassu) #4

Ja mam osobiscie win7 ale testuje strone na ie z win xp, bo klient placze ze na xp mu nie wyswietla obrazkow

 

Mr. ale na oryginalknym templacie na XP wszystko dziala. Dopiero p omoich przeróbkach coś nie trybi


(Thadrion) #5

a gdzie znajdują się te obrazki i jak wprowadzasz adres do nich? bo rozumiem z tematu, że to one się nie wyświetlają.

 

otwórz na IE źródło strony i spróbuj przejść bezpośrednio do obrazka.


(Karassu) #6

Zamieniam te obrazki z oryginalnymi czyt. usuwam obrazek i wrzucam o tej samej nazwie w to samo miejsce


(Neakles2) #7

IE8 wymaga dodania niektórych alternatywnych linijek kodu, stąd może być problem. IE8 nie obsługuje CSS3, dlatego trzeba używać starszych "kodów". Jeżeli używasz w kodzie do tła obrazka np. gradientu, to na 100% nie zostaną wyświetlone obie rzeczy.


(Karassu) #8

a czy są gdzieś spisane te kody pod IE8 ? czy nie bardzo


(Neakles2) #9

Szczerze mówiąc, nie mam pojęcia, bo ciężko to znaleźć. Trzeba omijać w linijkach dotyczących tych przeglądarek pewnych rzeczy lub stosować zamienniki, z których znam tylko jeden, na gradienty. Ponoć nie ma szans na stosowanie np. obrysów zaokrąglonych, dlatego trzeba szukać obejścia.