Excel funkcja jeżeli i jej szczegółowa informacja


(escort_) #1

Hej. Chciałbym zapytać czy da się zrobić żeby funkcje jeżeli która zwraca takie wartości

zwracała jeszcze informację np. ile dokładnie brakuje w stylu Brakuje - 46,90 zł

 


(floyd) #2

Np. tak:

=JEŻELI(C23-E23>=0;"Wyrównane";"Brakuje - ") & (E23-C23))


(rgabrysiak) #3

Cześć,

 

Załóżmy, że w komórce np. C2 mam wartość 30, a w komórce D2 wartość 25.

W komórce D4 chcę mieć formułę która sprawdzi mi ile brakuje w komórce D2 do wartości z komórki C2. W tym celu, w komórce D4 wpisuję poniższą formułę:


(escort_) #4

zastosowałem to co napisałeś: =JEŻELI(C23-E23>0;"Wyrównane +" & C23-E23;"Brakuje " &  C23-E23) i zaciekawiło mnie że jeśli brakuje to mam wpisane do 2 miejsc po przecinku, ale jak jest wyrównane to mam 12 miejsc po przecinku z tym że wartości w C23 i E23 też są do 2 miejsc po przecinku.


(rgabrysiak) #5

Cześć,

 

A jak masz "sformatowaną" komórkę w której wpisujesz funkcję (ile miejsc po przecinku)?


(floyd) #6

Excel traktuje komórkę do której wpisujemy tekst jako tekstową nawet jeśli występują też liczby. Nie bawiąc się w tłumaczenie jak w Excelu zaokrąglane są liczby należy w takim przypadku zaokrąglać te liczby do wybranej liczby miejsc po przecinku.

=JEŻELI(A1-B1>=0;"Wyrównane: " & ZAOKR(A1-B1;2);"Brakuje: " & ZAOKR(B1-A1;2))