Excel - jak używać Funkcji Licz.Jeżeli


(I.R.A.) #1

Witam, mam problem z funkcją Licz.Jeżeli

Chciałbym z podanego zakresu 100 liczb wyodrębnić ile liczb zawiera się w danym przedziale. [Edit]

Robię to tak (zgodnie z Help w MS Office):

excelk.th.jpg

Uploaded with ImageShack.us

Ktoś widzi gdzieś błąd, bo już skończyły mi się pomysły...


(Tomek Matz) #2

Funkcja Licz.Jeżeli zwraca informację o tym ile liczb ze wskazanego przedziału spełnia wybrany warunek. Z tego co zrozumiałem Ty potrzebujesz wypisać liczby, które spełniają wybrany warunek (tzn. zawierają się w wybranym przedziale), a nie ile liczb spełnia ten warunek.

Wstaw do komórki I2 taki warunek =JEŻELI(ORAZ(B2>=155;B2<156);B2;) i przeciągnij, aż do I101.


(I.R.A.) #3

Faktycznie, źle napisałem... Potrzebuje wskazać ile liczb zawiera się w danym zakresie, czyli tak jak napisałeś:

Przykład: Ile liczb w przedziale B2-B101 zawiera się w przedziale: 160-161

Gdzie popełniłem błąd?


(Tomek Matz) #4

Spróbuj w ten sposób:

=LICZ.JEŻELI(B2-B101;"<=161")-LICZ.JEŻELI(B2-B101;"<=160")


(I.R.A.) #5

"Formuła zawiera błąd"

Dałeś tam 2 razy "większe, bądź równe"

=LICZ.JEŻELI(B2-B101;" <=161")-LICZ.JEŻELI(B2-B101;" <=160")

ale nawet po zmianie na "mniejsze bądź równe" lub "mniejsze" ta funkcja nie działa...


(Tomek Matz) #6

Ma być dwa razy mniejsze, bądź równe. Zamiast : wstawiłem - w zakresie komórek :oops:. Spróbuj tak:

=LICZ.JEŻELI(B2:B101;"<=161")-LICZ.JEŻELI(B2:B101;"<=160")


(I.R.A.) #7

Faktycznie, teraz działa. Mógłbyś mi wytłumaczyć dlaczego tak? Żebym wiedział na przyszłość jak to zrobić :slight_smile: Dzięki wielkie za pomoc! :slight_smile:


(dark__jedi) #8

=LICZ.JEŻELI(B2:B101;"<=161")

analizujesz ilość liczb mniejszych lub równych od 161

LICZ.JEŻELI(B2:B101;"<=160")

analizujesz ilość liczb mniejszych lub równych od 160

łącząc (odejmując) te funkcje od siebie zostaje ci przedział od 160 do 161


(Tomek Matz) #9

Dokładnie tak jak napisał dark__jedi, ale wprowadź małą poprawkę. Zamiast <=161 zrób <161. Najlepiej przeanalizuj sobie to na prostym przykładzie.

Załóżmy, że w kolejnych komórkach masz takie liczby:

1 2 2 3 4 4 5 6 6

Masz teraz znaleźć ile jest liczb z przedziału powiedzmy 2-6.

Liczysz sobie ile jest liczb <= 2 i są 3 takie liczby.

Liczysz sobie ile jest liczb < 6 i jest 7 takich liczb.

7-3 = 4 (tj. są to liczby 3,4,4,5).


(I.R.A.) #10

Ok. Dzięki Panowie =D>

Lepiej zrozumieć i nauczyć się tego raz a porządnie, niż za każdym razem pytać na forum :slight_smile:

Teraz będe już wiedział jak używać tej funkcji :slight_smile:

Pozdrawiam!