Excel problem z formułą


(Ghostek111) #1

Witam, mam taki oto kod :

=JEŻELI(ORAZ(B2>=130;C2>=190)=PRAWDA;"wg";JEŻELI(LUB($B3<130;$C$3>=190)*PRAWDA;"w";JEŻELI(ORAZ(B4>=130;190>C4>=175)=PRAWDA;"śg";JEŻELI(LUB(B5<130;190>C5>=175)=PRAWDA;"ś";JEŻELI(ORAZ(B6>=130;175>C6>=160)=PRAWDA;"ng";JEŻELI(ORAZ(B7<130;175>A7>=160)=PRAWDA;"n"))))))

w tabeli mam napisane liczby kolejno dla B i C i ten kod ma za zadanie wpisać podane np. "wg" jeśli zgadzają się wartości podane w mojej tabeli. Niestety po wpisaniu kodu i "rozciągnięciu" go na pola, na pierwsze pole wskakuje tak jak ma być, czyli "wg", potem "ś", a potem samo "w", a wyskakuje to gdy nie zgadza się z wartościami w tabeli.. Co robie źlę? wiem że źle to opisałem, ale może ktoś się połapie o co chodzi. DZIĘKI WIELKIE ZA POMOC.


(Drobok) #2

Nie używasz $ by komórki wzorce nie zmieniały się podczas kopiowania. Ale bez przykładu raczej nie powiem ci co konkretnie masz zmienić :stuck_out_tongue:


(Semtex) #3

Witaj, popraw proszę tytuł tematu tak aby wstępnie informował o problemie, użyj przycisku EDYTUJ , który znajdziesz w prawym górnym rogu Swojego posta. Dobrze zatytułowany temat daje szansę na szybszą pomoc. Dziękuję za uwagę.

Tip: Unikaj słów: "problem", "help", "pomocy" i.t.p. Tego typu słowa nie spowodują szybszej reakcji a mogą odnieść odwrotny skutek od oczekiwanego, tytuł tematu ma być skróconym opisem Twojego posta- powodzenia.


(Ghostek111) #4

To moja tabela :

B C

1.138 192

2.132 176

3.137 164

4.112 168

5.126 192

6.124 198

7.118 179

8.120 159

to pomoże żeby ocenić co robie źle ?


(Dimatheus) #5

Hej,

Niestety nadal nie wiadomo, o co chodzi. Najlepiej wrzuć to do pliku Excela - w jednej zakładce wpisz wartości i odpowiednie formuły, a w drugiej - co powinno pojawić się w poszczególnych polach - czyli zamiast formuł gotowe wartości. I przydałoby się odpisać, kiedy mają pojawiać się określone wielkości - "wg", "ś" i tak dalej.

Pozdrawiam,

Dimatheus


(Ghostek111) #6

mam formułę która sprawdza podane wartości w tabeli oraz ma napisać tekst (wg, g, śg, ś, ng, n), gdy liczby spełniają te wartości..

a w kodzie jest wszystko umieszczone.. poprawiony co nieco kod, chociaż i tak nie działa..

=JEŻELI(ORAZ(B6>=130;C6>=190);"wg";JEŻELI(LUB(B3<130;C3>=190);"w";JEŻELI(ORAZ(B4>=130;190>C4;C4>=175);"śg";JEŻELI(LUB(B5<130;ORAZ(190>C5;C5>=175));"ś";JEŻELI(ORAZ(B6>=130;175>C6;C6>=160);"ng";JEŻELI(ORAZ(B7<130;175>A7;A7>=160);"n";"NIE SPEŁNIONE"))))))

(Drobok) #7

Skoro kod nie działa nic nikomu nie mówi. Daj konkretny przykład, kiedy co gdzie ma być (może jakiś schemat ? :P)


(rgabrysiak) #8

Przeniesiono z działu Na luzie.