Fglrx-nie działa aticonfig, Compiz i Emerald, Debian


(Julek94) #1

Witam

Po odrobinie przerwy zainstalowałem na powrót Debiana(Squezze). Miałem z nim troszkę problemów ale zima idzie to i więcej czasu bedzie, bateria mi nie jest zbyt często potrzebna to i bez acpi=off przeżyje. Instalacja poszła ok, zrobiłem głos itp. To se zainstaluje fglrx(otwartych nigdy mi sie nie udało) no i po kolei:

Debian~$ apt-get update

Debian~$ apt-get install module-assistant fglrx-driver fglrx-kernel-src


Kompilujemy i ładujemy sterownik

Debian~$ module-assistant prepare

Debian~$ module-assistant update

Debian~$ module-assistant a-i fglrx


Zmieniamy xorg.conf

Debian~$ aticonfig --initial

tylko zamiast apt-get używałem amptitude, dochodzę do tego miejsca:

debian:/home/mateuszek# aticonfig --initial

aticonfig: No supported adapters detected

debian:/home/mateuszek# aticonfig --initial

aticonfig: No supported adapters detected

debian:/home/mateuszek# glxinfo | grep direct

X Error of failed request: BadRequest (invalid request code or no such operation)

  Major opcode of failed request: 129 (GLX)

  Minor opcode of failed request: 19 (X_GLXQueryServerString)

  Serial number of failed request: 14

  Current serial number in output stream: 14

debian:/home/mateuszek# glxgears -printfps

Usage:

  -display set the display to run on

  -stereo run in stereo mode

  -fullscreen run in fullscreen mode

  -info display OpenGL renderer info

  -geometry WxH+X+Y window geometry

debian:/home/mateuszek#

nie mam pojęcia co dalej, zignorowałem ten błąd i spróbowałem zainstalowac compiza, nie działa. Dodam ze filmy można normalnie oglądać i już raz te sterowniki działały w miarę dobrze u mnie...... sprzęt z podpisu


(Kaka') #2

Pobierz ze strony ATI sterowniki dla swojej karty graficznej. Po ściągnięciu, odpal plik który ściągnąłeś. W razie dalszej niemożliwości odpalenia Compiza, pokaż logi z instalacji sterowników fglrx (/usr/share/ati/fglrx-install (lub coś w tym stylu)).


(Julek94) #3

http://support.amd.com/us/gpudownload/Pages/index.aspx nie ma tutaj mojej karty, nawet w wypadku sterowników do windows....

w podanym katalogu usr/share/ nie wiedzę ati, fglrx ani podobnego folderu......


(Kaka') #4

Pobierz zatem sterowniki dla ATI Mobility Radeon X1800 i spróbuj również ATI Radeon X1900 Series.


(Julek94) #5

ściągnąłem ale przy instalacji mam problem.... http://wklejto.pl/45998

instalacje usiłuje zrobić przy pomocy tego poradnika: http://www.debian.linux.pl/viewtopic.php?p=6246#6246

oraz http://www.debian.linux.pl/viewtopic.php?p=118#118

tak samo sie skończyło po wpisaniu na końcu Debian/testing oraz sid.....

To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.

dh_shlibdeps: dpkg-shlibdeps returned exit code 2

make: *** [binary] Error 1

dpkg-buildpackage: error: debian/rules binary gave error exit status 2

Removing temporary directory: fglrx-install.WULDjy

Generating package: Debian/squezze

Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions

Removing temporary directory: fglrx-install.gkxmC3

dodam ze mam wersję Squezze


(Kaka') #6

Nie generuj paczek, po prostu uruchom samą instalację.


(Julek94) #7

mam tą instalke(.run) na pulpicie. Nadaję jej prawo do wykonywania jako program. przy próbie uruchomienia(dwuklik uruchom) pojawia się na pulpicie folder który znika po kilku sekundach, przy wybraniu uruchom w terminalu terminal sam sie zamyka po krótkim czasie.... Jakieś pomysły? próbowałem zignorować ten moment ale jest jak było...

debian:/home/mateuszek# aticonfig --initial 

aticonfig: No supported adapters detected

(Kaka') #8

Uruchom terminal, wejdź do katalogu gdzie masz instalkę, odpal ją poprzez:

# ./ati-*

i pokaż ewentualny log z niepowodzenia instalacji.


(Falomir85) #9

sterowniki ATI działają z xorg-server<1.7

w repo debiana jest 1.6.5 chyba w niestabilnym, na nim działają bez problemów

pokaż log


(Julek94) #10
debian:/home/mateuszek/Desktop# ./ati-driver-installer-9-3-x86.x86_64.run

Created directory fglrx-install.uXxtZ3

Verifying archive integrity... All good.

Uncompressing ATI Proprietary Linux Driver-8.593...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

==================================================

 ATI Technologies Linux Driver Installer/Packager 

==================================================


Error: ./default_policy.sh does not support version

default:v2:i686:lib::none:2.6.30-2-686; make sure that the version is being

correctly set by --iscurrentdistro


Removing temporary directory: fglrx-install.uXxtZ3

debian:/home/mateuszek/Desktop#

pogrzebałem trochę ale nie widze tego logu w usr/share.... zrobiłem coś takiego ale to samo

debian:/home/mateuszek/Desktop# rm -f fglrx-install.uXxtZ3

debian:/home/mateuszek/Desktop# ./ati-driver-installer-9-3-x86.x86_64.run

Created directory fglrx-install.DTAhrA

Verifying archive integrity... All good.

Uncompressing ATI Proprietary Linux Driver-8.593...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

==================================================

 ATI Technologies Linux Driver Installer/Packager 

==================================================


Error: ./default_policy.sh does not support version

default:v2:i686:lib::none:2.6.30-2-686; make sure that the version is being

correctly set by --iscurrentdistro


Removing temporary directory: fglrx-install.DTAhrA

(dragonn) #11

Rozumie że to robisz przy wyłączonych x (chyba jednak nie bo po po prostu skopiowałeś to z terminala) i jako root


(Julek94) #12

why?

próbowałem też przy wyłączonych x'ach(killall gdm-chyba że to źle robie)ale jest to samo!


(dragonn) #13

To powiedz mi jak skopiowałeś to w poprzednim poście, bo chyba czegoś nie wiem. Czy są X wyłączone możesz sprawdzić dając CTRL + ALT + F7, jeżeli masz czarny ekran to jest okej, z tych błędów co wyczytałem to jest problem z wsparciem dla twojego jądra, pisze tam coś o parametrze --iscurrentdistro ale nie wiem co z tym zrobić.


(Kaka') #14

Wybierasz opcję instalacji czy tworzenia paczek?


(Julek94) #15

wpisałem to jak pisał Kaka' w terminalu, po przeczytaniu Twojej wypowiedzi zrobiłem to samo wyłączając x'y ale wynik był identyczny...

nie bardzo rozumiem: wpisałem polecenie które podałeś, instalator nie zadawał żadnych pytań, jeśli jednak chodzi o to jak bym chciał to zainstalować(w tym howtu było o stworzeniu paczek a Ty mówiłeś aby zainstalować) jest mi to obojętne, byle działało...

-- Dodane 04.11.2009 (Śr) 20:11 --

też to zauważyłem, ja nie mam ani tyle doświadczenia aby samemu wiedzieć czy nawet dojść do tego co zrobić z takim parametrem....


(dragonn) #16

Możesz spróbować dodać do polecenia:

./ati-driver-installer-9-3-x86.x86_64.run --iscurrentdistro

I zobaczyć co to da.