[Firefox] Partnerzy artykułu wychodzą z prawego boxa

błędy
firefox
portal

(krystian3w) #1

obraz


Firefox 57, Windows 10, nie ważne czy blokuje reklamy czy nie (grafika wciąż wychodzi jakoś na lewo).


Problem występuje jak sprawdzałem od Firefox 55+ na GNU/Linux, Android, Windows, MacOS.


(Dimatheus) #2

Hej,

Mam dokładnie to samo - FF 57.0.4 (x64), Windows 10 Home x64. Blokelów reklam nie używam wcale.

Pozdrawiam,
Dimatheus


(Radek68) #3

Ja się z tym nie spotkałem.
U mnie cały czas jest normalnie. Ale ja używam SlimJeta.



I BINGO!

Tak jest na Firefoksie!


(krystian3w) #4
Ta grafika ma z jakiegoś powodu podczepiony liniowo liczony margines lewy i prawy:

style="margin:0 calc((100% - 310px) / 2);"

<div class="progressiveMedia is-canvasLoaded is-imageLoaded" style="margin:0 calc((100% - 310px) / 2);">
...
</div>

Jak go wyłączyłem w narzędziach dev, to wróciła grafika na miejsce.


Jakiś konflikt z nowymi grafikami w artykułach?

Dodatkowo wychodzi że Blink w Chrome / Slimjet uznaje ten zapis wartości css ("0 calc((100% - 310px) / 2)") za błędny.


(wojtekadams) #5

FF 57.0.4 - Linux
to samo


(krystian3w) #6

Patrzę to problem może być też przez interpretowanie dziwnie “display: table-cell” w Firefox 55+.

Jak wyłączam je dla elementu <div class="table-cell"> to też wraca grafika na miejsce i margines jakby nie był liczony podobnie jak w Chrome (to że przesuwa się imię i nazwisko twórcy publikacji na razie pomijam).

<div class="table-cell">
	<a href="http://www.forumfilm.pl/index.htm" target="_blank">
		<noscript>
			<img src="..." style="width:310px;height:310px;" alt="image">
		</noscript>
		<figure class="graf-figure" data-id="255036">
			<div class="progressiveMedia is-canvasLoaded is-imageLoaded" style="margin:0 calc((100% - 310px) / 2);">
				<img class="progressiveMedia-thumbnail" style="width:310px;/*! height:310px; */" src="..." alt="image">
				<canvas class="progressiveMedia-canvas" style="width:310px;height:310px;" height="310" width="310"></canvas>
				<img class="progressiveMedia-image" style="width:310px;height:310px;" src="h..." data-src="..." alt="image"></div>
		</figure>
	</a>
</div>


Na tyle ile sprawdziłem problem występuje od Firefox 55, starsze wersje wyświetlają “dobrze”.


I problem występuje na każdej popularnej platformie: GNU/Linux, Android, Windows, MacOS - gdzie mamy pełnoprawny silnik przeglądarki Gecko.