Firefox zapisuje plik bez wcześniejszego otworzenia


(zielona_st) #1

Mam taki problem...

...gdy chcę otworzyć w przeglądarce jakiś plik pdf to automatycznie go ściąga. A ja chcę, żeby otwierało go w nowej karcie, tak jak wczesniej. Być może kliknęłam przez przypadek, podczas zpaisywania otwartego pilku, opcję, aby zapisywało mi plik za kazdym razem, ale jak to odkręcić? Widziałam już inne porady, żeby np. w Narzędzia->Opcje->ogólne w pobieraniu zaznaczyć, żeby pytało gdzie zapisać plik, ale mi chodzi o to, żeby plik tylko otwierał się w nowej karcie, a nie zapisywał. Innym wyjściem miało być Narzędzia->Opcje->Aplikacje w czynności zaznaczyć, żeby otwierało wtyczką w Firefoxie, ale tu zaskoczenie, bo przecież taką opcję mam już wybraną.

Jak to rozwiązać?


(manieKMP) #2

Wyłącz przeglądarkę, przejdź do katalogu profilu* i usuń plik mimeTypes.rdf, uruchom przeglądarkę i sprawdź co się stanie... usunięcie tego pliku powinno przywrócić domyślne ustawienia dla czynności wykonywanych na poszczególnych typach plików.

 

*Do katalogu profilu będzie najłatwiej dostać się przez adres about:support i kliknięcie na wyświetlonej stronie w przycisk "Pokaż folder".


(zielona_st) #3

Skutkuje :slight_smile: wyskakuje to okienko, teoretycznie problem rozwiązany, ale ja będę dążyła do tego, co było wcześniej :stuck_out_tongue:

jak jest teraz:

firefox -> klikam na link do jakiegoś pdf-u -> otwiera się plik w adobe reader poza przeglądarką

dla porówanania: chrome-> klikam na link do jakiegoś pdf-u ->otwiera się w przeglądarce

jak było wcześniej:

firefox -> klikam na link do jakiegoś pdf-u ->otwiera się w przeglądarce

co się przestawiło?


(manieKMP) #4

Czyli usunięcie wspomnianego pliku nie zadziałało?

 

Być może "magicznie" wbudowana przeglądarka pdf'ów została wyłączona :wink:

W about:config, ustawienie pdfjs.disabled powinno mieć wartość "false". Dodatkowo dla wbudowanej przeglądarki pdf'ów istotnym jest ustawienie plugin.disable_full_page_plugin_for_types z wartością "application/pdf" (ustawienie pojawia się przy przełączeniu na "Podgląd w programie Firefox" dla plików pdf w opcjach, w karcie "Aplikacje") i jeśli ono istnieje w about:config, a pdf'y się nie otwierają, należałoby to ustawienie zresetować (opcja "Resetuj" jest w menu kontekstowym, po kliknięciu prawym klawiszem myszy na ustawieniu/wpisie) i ponownie ustawić na "Podgląd w programie Firefox" w opcjach przeglądarki.

 

Przykładowy pdf z google do testu...


(zielona_st) #5

pdfjs.disabled powinno mieć wartość "false"   - sprawdziłam i ma wartość false

plugin.disable_full_page_plugin_for_types z wartością "application/pdf"  - tu też jest tak jak powinno być

 

Zamiast resetować weszłam w narzędzia->opcje->aplikacje  i ustawiłam pdf na podgląd w firefoxie. Teraz działa jak natura chciała  tak jak chciałam, żeby działało :stuck_out_tongue:

Wcześniej nie te aplikacje przełączałam (wg innych porad znetu...), a w tych pdf nie zauważyłam opcji podgląd w firefoxie, ale przecież ze mnie taka złota rączka (he he he), że już naprawiłam :smiley:

 

Dzięki