Formuła sumująca wystąpienia danego tekstu w arkuszach Google


(pocolog) #1

Potrzebuję formułkę, która w danym zakresie zsumuje wszystkie komórki zaczynające się od danego ciągu znaków.
Kombinowałem z takim łamańcem.

=suma(lewy(a1;3)="abc";lewy(a2;3)="abc")

O ile w LibreOffice taki zapis jest poprawny, bo wartość logiczna jest zapisywana jako 0 i 1 więc można je sumować, to w arkuszach Google zawsze dostaję wynik 0. Wygląda na to że tam wartość logiczna jest zapisywana w jakiś inny, magiczny sposób.

Może ktoś podpowie bardziej eleganckie rozwiązanie tego problemu?


(krystian3w) #2

https://sheet.zoho.com/sheet/excelviewer

Zoho calc

Widać wymaga ta formuła kompatybilności z Excelem - :confused:?


Zoho można jakoś podpiąć pod konto Google kiedyś tak testowałem jeszcze inne arkusze online ale tamte raczej padły.

Minus że na czas edycji trzeba tam wciąż używać angielskich nazw formuł:


=SUM(LEFT(A1;3)="abc";LEFT(A2;3)="abc")

(pocolog) #3

Angielskie nazwy formuł nie są dla mnie problemem, ale tak jak napisałem w pierwszym poście wymogiem jest działanie bezpośrednio w arkuszu Google.
Poza tym zależy mi na bardziej eleganckim rozwiązaniu, bo tylko dla przykładu użyłem 2 komórek, w rzeczywistości będzie ich o wiele więcej, ale ostatecznie to bym jeszcze przeżył.


(krystian3w) #4

W sumie wychodziło by że Google nie domyśla się że stosujemy coś podobnego do formuły jeżeli:

=SUMA((JEŻELI(LEWY(A1;3)="ABC";1;0));(JEŻELI(LEWY(A2;3)="ABC";1;0)))

I to już wygląda źle.


https://exceljet.net/formula/count-cells-that-contain-text - można sprawdzić czy takie formuły są w Google Sheet.

I by trzeba było ogarnąć by uznawało “abcd” - https://exceljet.net/formula/count-cells-that-contain-specific-text.


(pocolog) #5

Zrobiłeś jeszcze gorszego łamańca niż ja, ale przetestuję go jutro. Jeśli nikt nic lepszego nie wymyśli, to będę to klepał na akord :laughing:


(krystian3w) #6

=LICZ.JEŻELI(A1:A2;"abc*")

obraz


(pocolog) #7

No widzisz. Takie proste, a ja jak zwykle wszystko przekombinowałem :wink: Okres międzyświąteczny nie sprzyja myśleniu :smiley:


(krystian3w) #8

Albo zapominałeś o anglojęzycznym internecie.


(pocolog) #9

Zapomniałem że można tam gwiazdkę wstawić :sweat:
…a było wziąć urlop na 3 dni jak normalni ludzie :laughing: