Freewarówka Balls na Wine, potrzebny Direct3D


(kijek) #1

Cześć, chiałem sobie zagrać w freewarówkę o tytule (I've got some) Balls, podczas uruchamiania wyświetla błąd:

No Direct3D

Switching to software resterizer.

Jak się tego pozbyć ? Wersja Wine to 1.0


(system) #2

Sprawdź na stronce wine, czy jest obsługiwana...


(kijek) #3

Tej gierki nie ma na stronie Wine, ale taki sam mam problem z Medal Of Honor Alied Assault tylko, że błąd wygląda inaczej.


(matiit) #4

Doinstaluj DirectX (poszukaj opisu na necie) + postaraj sie o najnowsze wine.


(kijek) #5

DirectX został zainstalowany przez wine.


(system) #6

Spróbuj Play On Linux


(kijek) #7

Zabawa z kompilacją Wine 1.1.5 skończyła się na wypakowaniu plików, ponieważ po wpisaniu:

./configure

Konsola wywala:

bash: ./configure: No such file or directory

Pewnie robię coś źle, jakieś parametry trzeba dodac po ./configure, ale nie mam pojęcia jakie, u mnie z angielskim nie najlepiej, więc chyba na razie mogę sobie tylko pomarzyć o Wine 1.1.5.

Zapomniałem podać ścieżki do folderu w którym się rozpakowało, teraz muszę zainstalować jakąś paczkę flex.


#8

Podstawowe, może głupie pytanie - masz zainstalowane sterowniki do karty graficznej?


(kijek) #9

No, sterowniki zainstalowane.

Tak dokładniej, to co to w ogóle jest to Play On Linux wiem, że jest to coś pod styl wine, ale nie wiem, czym się różni, itd. mógłby mi to ktoś wytłumaczyć.


(matiit) #10

A wynik polecenia

glxinfo | grep direct

co pokazuje?


(kijek) #11

polecenie

glxinfo | grep direct

pokazuje

direct rendering: Yes

czyli to co powinno (chyba) pokazywać.


(rgabrysiak) #12

http://thecamels.org/2008/03/13/playonlinux/#more-881


(kijek) #13

No chciałem zainstalować to PlayOnLinux, ale wymaga paczek: python-wxgtk2.8 i lzma, których nie ma w menadżerze oprogramowania, jest niby python-wxgtk, ale w wersji 2.6, pomoże ktoś ?


(nintyfan) #14

Mogę podesłać starszą wersję PlayOnLinux, która nie wymaga tych paczek.


(kijek) #15

Chodź panowie z ola-os.com obiecali mi te paczki, to bym poprosił o tą starszą wersję.

Ok, panowie z ola-os.com przygotowali już mi te paczki, lecz teraz mam problem z POL, chciaolbym sobie uruchomić coś, co jest już na dysku, a nie za pomocą wbudowanej instalacji, pomoże ktoś ? E.. czytałem gdzieś, że można w POL wyemulować DirectX, ale jak to zrobić ?