Funkcja jeżeli w excelu - błąd


(Kidler) #1

Witam. stworzyłem w Excelu funkcje:

=JEŻELI(A4>0;SUMA(A4;C4);JEŻELI(B4>0;różnica(B4;C4)))

i okazuje się że jeżeli a4 jest równe 0 a b4 np. 50 to wywala komunikat #NAZWA? dlaczego?


(andhla) #2

W Excelu nie ma funkcji: różnica


(floyd) #3

Ponieważ odejmowanie można zawsze zastąpić dodawaniem liczby przeciwnej i wprowadzanie dodatkwej funkcji jest zbyteczne. Przykład kidlera można zatem przedstawić tak:

=JEŻELI(A4>0;SUMA(A4;C4);JEŻELI(B4>0;SUMA(B4;-C4)))