Funkcja w excelu wybierająca największą średnią+nazwisko


(urz) #1

Witam, potrzebuję funkcję, która wybierze mi trzy największe średnie ocen razem z nazwiskiem uczniów. Proszę o pomoc. Nazwisko i imię to jedna kolumna, średnia danego ucznia druga (ale nie sąsiadująca).

Dziękuję z góry!


(Drobok) #2

Napisz co chcesz z tym później zrobić ;p


(urz) #3

drobok, mam zestawienie ocen klasy. Każdy uczeń uzyskał jakąś średnią ocen. Zrobiłam tabelkę, w której chcę przedstawić trzy największe średnie uzyskane w klasie i trzy najmniejsze. Chciałabym, żeby program wybierając mi te najlepsze i najgorsze średnie przypisał im również nazwisko ucznia (żebym nie musiała wpisywać "na piechotę"). Wszystko to w obrębie jednego skoroszytu.


(Drobok) #4

Załóżmy że chcesz mieć 3 wartości w 3 komórkach korzystasz wtedy z jeżeli oraz max.k

np =JEŻELI(MAX.K(tablica;która największa)=kom z średnią;kom z nazwiskiem;JEŻELI(MAX.K(tab;która)=komórka z średnią;komórka z nazwiskiem;""))

edit rozumując z twego pierwszego postu imię i nazwisko masz w jednej komórce skorzystaj wtedy z funkcji lewy oraz znajdź np =LEWY(B2;ZNAJDŹ(" ";B2;1))

=lewy(kom z textem;znajdź(" ";kom z textem;1))

wtedy znajdź jest parametrem do funcji lewy co zpowoduje wyświetlenie pierwszego wyrazu


(dark__jedi) #5

Można także przesortować tabelę po średniej ocenie i wynik sam się układa.

Zaletą tego rozwiązania jest to, że mamy całą klasę posortowaną rosnąco lub malejąco.


(urz) #6

..nie rozumiem.... (dot. drobok)

-- Dodane 25.05.2010 (Wt) 20:59 --

Niby tak, ale muszę mieć ich alfabetycznie. A te "maxy" i "min" oddzielnie.


(Drobok) #7

rozumiem z twojej wypowiedzi że masz 2 komórki tj nazwisko imie / średnia

więc aby wyświetlić 3 najlepsze odpowiedzi zaproponowałem ci skorzystać z 3 komórek max1 max2 i max3

zakładając że nazwisko imie masz w b1itd średnią w c1itd piszesz

=JEŻELI(MAX.K(C1:C2;1)=C1;=LEWY(B1;ZNAJDŹ(" ";B2;1));JEŻELI(MAX.K(C1:C2;1)=C2;=LEWY(B2;ZNAJDŹ(" ";B2;1));""))

i tak w kółko aż do wpisania wszystkich wierszy


(urz) #8

Dzięki drobok :smiley: