Gimp - script - fu - błąd podczas wczytywania skryptu


(Ziemia93) #1

Witam.

Wrzuciłem plik ze skryptem do katalogu C:\Documents and Settings\user\gimp-2.6\scripts. Uruchomiłem gimpa w script - fu, nie ma go, gdy odświeżam skrypty wyświetla się nst. komunikat

22fd7c6fc55c974bm.png

Używam Gimpa 2.6.


(Olixxx94) #2

Tak masz ze wszystkimi skryptami czy tylko z tym jednym? Skąd właściwie masz ten skrypt?


(Dimatheus) #3

Hej,

Mnie w tej sytuacji nasuwają się dwa tropy:

:arrow: coś nie tak ze skryptem, bo w lokalizacji błędu mamy zdublowane " **" - a to chyba normalne nie jest,

:arrow: znaki diakrytyczne w ścieżce dostępu - niektóre programy są na to bardzo wyczulone - być może GIMP też.

Pozdrawiam,

Dimatheus


(Ziemia93) #4

Póki co ze wszystkimi (czyt. z dwoma :P) a skrypty jeden z http://registry.gimp.org/node/5921 a drugi z http://kward1979uk.deviantart.com/art/s ... 4-30198844

Zauważ, że zdublowane jest tylko gdy ścieżka podawana jest po angielsku po polsku jest, ok

Zmieniłem nazwe pliku na s.scm i nie pomogło :frowning:


(Dimatheus) #5

Hej,

Pisząc o znakach diakrytycznych miałem na myśli to ł w nazwie użytkownika, a nie znaki specjalne w nazwie pliku. :slight_smile:

Pozdrawiam,

Dimatheus


(Ziemia93) #6

Aha :stuck_out_tongue:

Nawet jeśli no to nie pomogło :frowning:


(Olixxx94) #7

A spróbuj go przenieść do X:/GIMP-2.0/share/gimp/2.0/scripts, gdzie X to partycja z zainstalowanym GIMP-em.

Drugi ze skryptów na pewno jest poprawny.


(Ziemia93) #8

No więc błędów żadnych nie ma i filtru w script-fu też nie :stuck_out_tongue:


(Olixxx94) #9

Jeśli szukasz w Filtry->Script-fu to go tam nie znajdziesz. Po w/w zakładce powinna się utworzyć nowa z nazwą Script-fu->gimp-talk.com->sketch...


(Ziemia93) #10

Wytłumacz mi to "jak dziecku" gdzie mam tego szukać :stuck_out_tongue:


(Olixxx94) #11

W oknie obrazu oczywiście. Dalej j/w


(Ziemia93) #12

Nie ma, albo ja źle szukam

kdb.th.png


(Dimatheus) #13

Hej,

Więc zrobimy wszystko krok po kroku... :slight_smile:

:arrow: Wrzucasz ściągnięte skrypty do katalogu D:\Documents and Settings\Nazwa_Użytkownika.gimp-2.6\scripts

:arrow: Uruchamiasz GIMP'a,

:arrow: W oknie obrazka wybierasz po kolei Menu -> Filtry -> Script-Fu -> Odśwież skrypty,

y75gjeozrxnr4hztoz_thumb.png

:arrow: Po operacji tej powinny pojawić się dostępne skrypty:

:idea: quick-sketch pojawi się w pozycji Filtry - Artystyczne - Quick sketch

o2ohxaw6v5dg2k2w77b0_thumb.png

:idea: sketch_script_fu_now_2_4 pojawi się w nowej pozycji menu - Script-Fu- Gimp-talk.com- sketch

4ob44y8xgagubgxfwtxo_thumb.png

Mam nadzieję, że teraz wszystko będzie już działać... :slight_smile:

Pozdrawiam,

Dimatheus


(Ziemia93) #14

Po pierwsze doceniam to, że tak "obrazkowo" i szczegółowo - jak dziecku ;] mi to wytłumaczyłeś ale problem w tym że ja od początku robię tak jak to opisałeś i pojawiają się te błędy


(Olixxx94) #15

Spróbuj przenieść do lokalizacji, o której pisałam wczesniej i dopiero po tym odśwież skrypty.


(Ziemia93) #16

O teraz działa :o

Wielkie dzięki WSZYSTKIM za pomoc :slight_smile:


(Dimatheus) #17

Hej,

Cieszymy się niezmiernie... :slight_smile:

Ale powiem, że zastanawiało mnie, co jest przyczyną problemu. Na maszynie wirtualnej na koncie użytkownika Michał zainstalowałem Gimp'a w najnowszej wersji. W katalogu C:\Documents and Settings\Michał.gimp-2.6\scripts umieściłem dwa skrypty i po odświeżeniu otrzymałem dokładnie takie same błędy jak Ty. Następnie przelogowałem się na drugie konto w systemie wirtualnym - Dimatheus (czyli bez znaków diakrytycznych) - odpaliłem Gimpa, by utworzył odpowiednią strukturę katalogów, wrzuciłem skrypty do katalogu C:\Documents and Settings\Dimatheus.gimp-2.6\scripts, odświeżyłem i co - oczywiście zadziałało. :slight_smile: Trzeba więc przyznać, że błąd wynika z użycia polskiego znaku diakrytycznego w nazwie użytkownika systemu.

Swoją drogą to niezbyt zdrowe używać takowych znaków w nazwie użytkownika - szczególnie w systemach do Windows XP.

Pozdrawiam,

Dimatheus