Głębia koloru na Linux Mint, jak to sprawdzić i ewentualnie zmienić


(kamaza) #1

Jak w temacie, jak sprawdzić i ewentualnie zmienić ustawienie Colour Depth ?

Niestety nie za bardzo idzie mi znalezienie tej opcji w Mincie18.1 , i ogólnie rozwiązania.

Dziękować :slight_smile:


(pocolog) #2

Jeśli masz kartę graficzną nvidia, to w jej ustawieniach (nvidia-settings) powinna być możliwość zmiany głębi kolorów. Jeśli nie to dodaj w pliku /etc/X11/xorg.conf takie coś:

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth XX
SubSection "Display"
Depth XX
EndSubSection
EndSection

Gdzie XX zastąpisz swoją wartością np 16. Jeśli plik nie istnieje to taki stwórz.
Xy domyślnie wstają z maksymalną dostępną głębią.


(Domker) #3

Jeżeli używasz karty graficznej Nvidia to w “Nvidia X Server Settings”.
Innym sposobem to wpisanie w konsoli:

cat /etc/X11/xorg.conf | grep “Depth”

Co powinno zwrócić tego typu wynik:

DefaultDepth    24
Depth       24

Po co Ci zmiana głębi koloru ??
Można zrobić to w konfigu, ale przy nieodpowiedniej wartości może wykrzaczyć Ci się X.org i co zrobisz? :stuck_out_tongue:
Trzeba wtedy będzie się spod konsoli ratować :wink:


(marcin82) #4

Sprawdź taką komendą:


(kamaza) #5

Dzięki zadziałało. 24 bity na Mincie, winda 32 bity. Co do xorg, nic mi tu nie działa, nie ma, nie znalazłem, nie widzę, … pewnie trza coś doinstalować ? Bo w temacie xorg nic na kompie nie grzebałem, za cienki i za nowy jestem w pingwinku.

Generalnie chodzi o to że ktoś z działu technicznego producenta gry zasugerował ustawienie na Mincie tej samej głębi koloru, co na windzie. Aktualnie instalka gry jest na windzie, i odpalam to Wine’m.

To teraz tak myślę, skoro odradzacie zmianę Colour Depth na Micie, to może zmienić w dół ten parametr na windzie 7 ? z 32 na 24 ? Mniejsze ryzyko ?

Czy odpuścić temat i grać na windzie.


(Domker) #6

Tutaj głębia koloru nie ma nic do rzeczy. Gra jak będzie chciała to przełączy sobie głębie kolorów w trybie pełnoekranowym.