Gparted i instalator ubuntu nie widzą partycji Windows


(Radoslaw W Zielinski) #1

Cześć. Mam jeden problem. Zakupiłem sobie nowy komputer, który został złożony w sklepie. Z sporym dyskiem. Zainstalowałem na nim Windows 7 Professional. Chciałem sobie doinstalować tak dla nauczenia się czegoś którąś dystrybucję Linuxa. Dla tego też z partycji, na której trzymam pliki uciąłem 60GiB. Potem wypaliłem sobie Ubuntu 12.10, które pobrałem z dobreprogramy.pl. Chciałem zainstalować go zainstalować przy okazji wykorzystując jego wbudowane narzędzia do partycjonowania. Niestety nie udało mi się to, ponieważ podczas próby odpalenia się instalatora całość się przerwała i wyświetlił mi się ten komunikat:

(initramfs) unable to find a medium containing a live file system

Szperałem i się doszperałem ciekawego rozwiązania. Mianowicie ktoś gdzieś napisał, że jeśli mam wpięty dysk i napęd na dodatkowych portach SATAIII to taki problem może wyniknąć. Doradzono żebym przepiął je na port nr 1 i nr 2, które są SATAII

W tym momencie dochodzę do meritum sprawy. Po zainstalowaniu instalator Ubuntu, a następnie GParted, którym chciałem się upewnić pokazywały mi, że dysk w ogóle nie jest zajęty i całe 500GiB jest wolne.

Pytanie do Was, co może być przyczyną? Jak się z tym uporać? I ostrzegam, że w takich sprawach jestem kompletnym laikiem i próba wyjaśnienia mi tego, przy pomocy żargonu mija się z celem.

Płyta główna to: MSI 760GA-P43 (FX)

Dysk twardy: Seagate Barracuda 500GB

Podział na partycje Windows dokonałem podczas instalacji systemu


(bobbi) #2

Port SATA nie jest zbyt istotny.

Ważny natomiast jest tryb pracy dysku jako IDE lub AHCI ustawiony w Biosie.

Rekomendowanym w tym wypadku jest AHCI.

Zmiana w Biosie może natomiast spowodowac problemy z uruchomieniem Windows jeśli nie są zainstalowane sterowniki dla tego trybu.


(Radoslaw W Zielinski) #3

@bobbi niestety zaskoczę Cię, ale różnica jest i to kolosalna. Po przełączeniu trybu pracy dysku na AHCI nadal przy podpięciu do SATAIII nie chciał instalator ubuntu ani gparted startować, a po przepięciu nadal pokazywało mi, że dysk jest czysty i chciało go formatować