GRUB - błąd po usunięciu partycji z ubuntu


(Hryniewicki Jarek) #1

Zainstalowałem z ciekawości Ubuntu 11.04 na drugim dysku (tego z Windowsem nic nie ruszałem). Po zbadaniu nowości usunąłem partycje z Ubuntu jednak coś mi się skrzaczył GRUB. nie mogę teraz uruchomić ani Windowsa ani Ubuntu (które ponownie zainstalowałem licząc że jakoś się grub naprawi, lol?).

Po pojawieniu się ekranu HP zwykle wyskakiwał grub lub zaczął wczytywać Windows, a teraz:

error: no such device: 67f2a4fa-ee13-4209-81ad-f3bc82b78dae.

grub rescue> _

I choćbym nie wiem co próbował wpisać wyskakuje Unkown command Próbowałem skorzystać z wiersza poleceń z płyty windy ale po wpisaniu FIXBOOT i FIXMBR wyskakuje:

X:\ Sources> fixboot

Nazwa "fixboot" nie jest rozpoznawalna jako polecenie wewnętrzne lub zewnętrzne, program wykonywalny lub plik wsadowy

Nie mam pojęcia co dalej, na PC nigdy z grubem nie miałem problemów a na laptopie od razu takie akcje... Aha, dodam że instalowałem systemy w wersji 64bit.

Siedzę obecnie na livecd i jestem już tą sytuacja trochę zdenerwowany więc wybaczcie ewentualne błędy w tekscie.


(Gregorsi) #2

Windows w jakiej wersji? Jeżeli WinXp to fixboot i fix mbr powinno zadziałąć.

to mi sugeruje winPe, więc należy użyć BCDEDIT.

W WinPe/WinRe nie występuje Fixboot i fixmbr, jeżeli chcesz naprawić XP należy użyć płyty instalacyjnej WinXP.


(Marcdrs99) #3

W konsoli naprawczej wpisz :

C:

CD \

FIXBOOT C:

FIXMBR

BOOTCFG /rebuild


(Hryniewicki Jarek) #4

To jest Windows 7 64bit, a co do komend które podał @vlad99 to juz to próbowałem i nic nie daje.


(GioWDS) #5

Bo tych poleceń nie ma w Windows 7 - występują w płycie instalacyjnej XP, ale to Ci wiele nie pomoże.


(Gregorsi) #6

Jeżeli Win7 to uruchom naprawę z płyty instalacyjnej.


(Hryniewicki Jarek) #7

Chciałbym aby to pomogło, niestety próbowałem już tak przywracać system to wcześniejszego stanu, skorzystac z opcji naprawiającej start systemu i nic to nie dało. Została mi tylko opcja wiersza poleceń, odzyskanie systemu z obrazu (też nie działa) i reinstalacja.

Błąd widocznie jest po stronie gruba, trochę czytałem i podobno dysk zgubił jakąś etykietę czy coś, ale nie wiem jak to naprawić.


(Gregorsi) #8

Dysk nie zgubił etykiety tylko wykasowałeś partycję zawierającą plik konfiguracyjny grub. Usunąłeś /boot/grub/grub.cfg to skąd niby twój grub ma wyświetlić menu i wiedzieć co uruchomić?

Uruchom komputer z GpartedLiveCD (lub UbuntuLiveCD i uruchom program Gparted) i zobacz czy partycja na której jest Windows jest oznaczona jako aktywna (flaga ustawiona na boot) , Możesz też to sprawdzić płytą instalacyjna Win7 za pomocą DISKPART. Jeżeli nie jest aktywna to ustaw ją i ponów naprawę systemu.


(Hryniewicki Jarek) #9

Nie wiem czemu, ale gparted pokazuje mi że dysk z windowsem jest "unallocated" co dziwne bo z poziomu LiveCD ubuntu mogę normalnie przeglądać jego zawartość...

W ogólę się zdziwiłem bo przy dzieleniu dysku przy instalacji ubuntu w ogóle na liście nie było systemu plików NTFS, w ostatnim ubuntu jakiego używalem (9.10) było NTFS a teraz lipa.

EDIT: Udało mi się uruchomić windowsa, pomocna byla komenda bootrec /fixmbr

Podejrzewam że teraz wystarczy szybki reinstall ubuntu i powinno być cacy :wink: