Grub nie ładuje się przy starcie komputera


(Ras96pl) #1

Witam. Mój problem jest dość dziwny, otóż po włączeniu komputera nie startuje grub. Dzieje się tak od momentu instalacji Debiana 7, która z resztą zawiesiła się w momencie instalcji gruba. Próbowałem już czyszzenia MBRu i instalacji na nowo gruba przez chroot, oraz instalacji Ubuntu 13 bez jakiegokolwiek skutku. Wcześniej na komputerze działał Gentoo i Arch pod którymi podobnych problemów nie było. Podejrzewałem że jest to wina GPT, jednak nie znam go na tyle dobrze bo móc samemu sobie poradzić. Z góry dziękuję, pozdrawiam.


(roobal) #2

Jakiego Debiana instalowałeś, 32 czy 64-bit? Instalowałeś go na Ext4 czy na Btrfs? Możliwe, że to wina GPT, choć u mnie 32-bitowy Debian zainstalował się bez problemu, za to podobne problemy miałem przy instalacji 64-bitowego Debiana na Btrfs (na 32-bitowym żadnego problemu), więc w przypadku GPT może być podobnie.


(Ras96pl) #3

Ext4 system 64bit, te same problemy na Ubuntu 13 64bit. .Próbowałem z grubem na partycji EFI i na ext2. Na Ubuntu udało mi się oodpalić system po wyczyszczeniu dysku z partycji, stworzeniu nowej tablicy partycji, wyczyszczeniu MBRu, chrootowaniu na zainstalowany system, odinstalowaniu starego grub-efi ( domyślnie instaluje się grub-efi, pomimo że partycjonowałem ręcznie i nie stworzyłem partycji efi) i zainstalowaniu zwykłego gruba :smiley: Jutro spróbuję tego z debianem a jak nie pomoże to instaluję wersję 32bit


(mati75) #4

Ilość bitów tu jest bez różnicy. Problem musi leżeć gdzie indziej. Spróbuj z tego obrazu zainstalować: http://cdimage.debian.org/mirror/cdimag … etinst.iso Na jednej płycie jest 32 i 64 bit, można się pobawić jakby co :smiley:


(roobal) #5

Widocznie nie jest bez różnicy, na 64-bitowym Debianie miałem identyczne problemy, na 32-bitowym zero problemów. Możliwe, że są jakieś błędy w tych edycjach systemu.


(Ras96pl) #6

Witam ponownie. Od momentu napisania pierwszego posta próbuję rozgryźć ten problem i nie mam już pojęcia co tak naprawdę nie działa a co działa. Próbowałem postawić Debiana (64 bit) w ten sam sposób jednak Grub tym razem się zawiesza. Zauważyłem że pomimo ręcznego partycjonowania instalator debiana zostawia przed pierwszą partycją 1 MB wolnego miejsca na dysku i podejrzewam że ten błąd jest spowodowany błędnymi sektorami partycji. Została mi próba Debiana 32 bit i ewentualnie partycjonowanie za pomocą fdisk.


(marcin82) #7

Podaj wynik skryptu bootinfoscript :

http://sourceforge.net/projects/bootinfoscript/ .

To powinno wiele wyjaśnić.