Grub - nie znajduje Windowsa


(Attendite) #1

Posiadam 2 dyski:

IDE 1 slave 40 GB

IDE 2 master 200 coś GB

Na master jest ubuntu oraz GRUB [pozwala wybierać z zainstalowanych systemów operacyjnych przy uruchamianiu komputera]

Na slave, tym większym mam Windowsa XP. Problem w tym, że odkąd wczoraj sformatowałem matstera i zainstalowałem na nim nowego ubuntu [a przy tym także GRUB'a], podczas uruchamiania kompa wyświetlane mi są tylko UBUNTU, UBUNTU recovery mode, i jeszcze jakaś trzecia opcja UBUNTU.

Co mogę z tym zrobić ? Ubuntu wyświetla mi ten drugi dysk z windowsem, problem w tym, że nie mam pojęcia jak teraz tego windowsa uruchomić!


(matiit) #2

Pokaż nam wyniki dwóch poleceń:

sudo fdisk -l

cat /boot/grub/menu.lst

(Attendite) #3

sudo fdisk -l

hack@hack:~$ sudo fdisk -l

[sudo] password for hack:


Disk /dev/hdb: 250.0 GB, 250059350016 bytes

255 heads, 63 sectors/track, 30401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x00000001


   Device Boot Start End Blocks Id System

/dev/hdb1 2 8121 65223900 f W95 Ext'd (LBA)

/dev/hdb2 * 8122 17045 71682030 7 HPFS/NTFS

/dev/hdb3 17046 30401 107282070 7 HPFS/NTFS

/dev/hdb5 2 8121 65223868+ 7 HPFS/NTFS


Disk /dev/hdc: 40.0 GB, 40020664320 bytes

255 heads, 63 sectors/track, 4865 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0xf603f603


   Device Boot Start End Blocks Id System

/dev/hdc1 1 4865 39078081 83 Linux

hack@hack:~$

cat /boot/grub/menu.lst

hack@hack:~$ cat /boot/grub/menu.lst

# menu.lst - See: grub(8), info grub, update-grub(8)

# grub-install(8), grub-floppy(8),

# grub-md5-crypt, /usr/share/doc/grub

# and /usr/share/doc/grub-doc/.


## default num

# Set the default entry to the entry number NUM. Numbering starts from 0, and

# the entry number 0 is the default if the command is not used.

#

# You can specify 'saved' instead of a number. In this case, the default entry

# is the entry saved with the command 'savedefault'.

# WARNING: If you are using dmraid do not use 'savedefault' or your

# array will desync and will not let you boot your system.

default 0


## timeout sec

# Set a timeout, in SEC seconds, before automatically booting the default entry

# (normally the first entry defined).

timeout 3


## hiddenmenu

# Hides the menu by default (press ESC to see the menu)

hiddenmenu


# Pretty colours

#color cyan/blue white/blue


## password ['--md5'] passwd

# If used in the first section of a menu file, disable all interactive editing

# control (menu entry editor and command-line) and entries protected by the

# command 'lock'

# e.g. password topsecret

# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

# password topsecret


#

# examples

#

# title Windows 95/98/NT/2000

# root (hd0,0)

# makeactive

# chainloader +1

#

# title Linux

# root (hd0,1)

# kernel /vmlinuz root=/dev/hda2 ro

#


#

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST


### BEGIN AUTOMAGIC KERNELS LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified

## by the debian update-grub script except for the default options below


## DO NOT UNCOMMENT THEM, Just edit them to your needs


## ## Start Default Options ##

## default kernel options

## default kernel options for automagic boot options

## If you want special options for specific kernels use kopt_x_y_z

## where x.y.z is kernel version. Minor versions can be omitted.

## e.g. kopt=root=/dev/hda1 ro

## kopt_2_6_8=root=/dev/hdc1 ro

## kopt_2_6_8_2_686=root=/dev/hdc2 ro

# kopt=root=UUID=8c29b629-6f4b-49b8-a538-1916b37ea638 ro


## Setup crashdump menu entries

## e.g. crashdump=1

# crashdump=0


## default grub root device

## e.g. groot=(hd0,0)

# groot=(hd1,0)


## should update-grub create alternative automagic boot options

## e.g. alternative=true

## alternative=false

# alternative=true


## should update-grub lock alternative automagic boot options

## e.g. lockalternative=true

## lockalternative=false

# lockalternative=false


## additional options to use with the default boot option, but not with the

## alternatives

## e.g. defoptions=vga=791 resume=/dev/hda5

# defoptions=quiet splash


## should update-grub lock old automagic boot options

## e.g. lockold=false

## lockold=true

# lockold=false


## Xen hypervisor options to use with the default Xen boot option

# xenhopt=


## Xen Linux kernel options to use with the default Xen boot option

# xenkopt=console=tty0


## altoption boot targets option

## multiple altoptions lines are allowed

## e.g. altoptions=(extra menu suffix) extra boot options

## altoptions=(recovery) single

# altoptions=(recovery mode) single


## controls how many kernels should be put into the menu.lst

## only counts the first occurence of a kernel, not the

## alternative kernel options

## e.g. howmany=all

## howmany=7

# howmany=all


## should update-grub create memtest86 boot option

## e.g. memtest86=true

## memtest86=false

# memtest86=true


## should update-grub adjust the value of the default booted system

## can be true or false

# updatedefaultentry=false


## should update-grub add savedefault to the default options

## can be true or false

# savedefault=false


## ## End Default Options ##


title Ubuntu 7.10, kernel 2.6.22-14-generic

root (hd1,0)

kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=8c29b629-6f4b-49b8-a538-1916b37ea638 ro quiet splash

initrd /boot/initrd.img-2.6.22-14-generic

quiet


title Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)

root (hd1,0)

kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=8c29b629-6f4b-49b8-a538-1916b37ea638 ro single

initrd /boot/initrd.img-2.6.22-14-generic


title Ubuntu 7.10, memtest86+

root (hd1,0)

kernel /boot/memtest86+.bin

quiet


### END DEBIAN AUTOMAGIC KERNELS LIST

hack@hack:~$

Z góry dzięki, mam Windowsa ale... nie mogę do niego dotrzeć!


(matiit) #4

Dodaj na koncu pliku:

title Windows 95/98/NT/2000

root (hd0,0)

makeactive

chainloader +1

(Attendite) #5

Wybacz... którego pliku ?


(matiit) #6

/boot/grub/menu.lst

Robisz to tak:

sudo gedit /boot/grub/menu.lst

Dopisujesz co podałem.

Zapisujesz i zamykasz.

Uruchamiasz ponownie komputer.


(Attendite) #7

W GRUBIE pojawił się Windows, ale po jego wybraniu mam

Error 12: Invalid device requested

Czy to "niepodobieństwo":

title Ubuntu 7.10, kernel 2.6.22-14-generic

root (hd1,0)

kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=8c29b629-6f4b-49b8-a538-1916b37ea638 ro quiet splash

initrd /boot/initrd.img-2.6.22-14-generic

quiet

do:

title Windows 95/98/NT/2000

root (hd0,0)

makeactive

chainloader +1

Jest ok ?


(matiit) #8

Zamień ten cały wpis z windowsem na:

title XP

rootnoverify (hd0,0)

makeactive

chainloader +1

(Attendite) #9

Niestety, ale nawet po tej zmianie mam

Error 12: Invalid device requested

Ale już coś, wyświetla się, tylko zła ścieżka. Pytanie do Ciebie - jaka w takim razie jest dobra ? :wink:


(matiit) #10

Nie zrozumiałem bardzo Twojego postu. (tego ostatniego) TTTx 22.01.2008 (Wt) 19:16


(Fisiu) #11

matiit a czy aby nie trzeba jeszcze zmapować dysków?? Bo coś mam wrażenie, że bez tego ani rusz...


(Attendite) #12

Nie zrozumieliście mojego posta więc wyjaśniam:

zrobiłem tak jak mi poleciliście 2 posty wyżej, ale mam dalej ten sam błąd jak wybiore windowsa z listy GRUBA.

Mapowanie dysków ? :wink:


(matiit) #13

Fisiu

Ja miałem windowsa i linuksa i nigdy nie mapowałem.

Windows na 0,0 Linux na 1,0 ale instalowany na mbr dysku pierwszego. Zawsze to działało bez najmniejszego zająknięcia.

Ale niech spróbuje.

TTTx

Spróbuj tego:

title XP

    map (hd0) (hd1)

    map (hd1) (hd0)

    chainloader (hd0,0)+1

(Fisiu) #14

TTTx dla świętego spokoju, podaj jeszcze

cat /boot/grub/device.map

(Attendite) #15
hack@hack:~$ cat /boot/grub/device.map

(hd0) /dev/hdb

(hd1) /dev/hdc

hack@hack:~$

hdb i hdc ? Możecie po krótce wyjaśnić ?


(matiit) #16

/dev/hdb - Twój dysk podłączony jako master primary

/dev/hdc - Twój dysk podłączony jako slave primary.

Wkleiłeś do menu.lst co podałem?


(Attendite) #17

Oczywiście.

W miejscu Windowsa

title XP

    map (hd0) (hd1)

    map (hd1) (hd0)

    chainloader (hd0,0)+1

Ale teraz jak wybiorę z listy Windowsa, to

Starting up...

I tak mogę sobie czekać do... do niewiadomo kąd :wink:


(matiit) #18

Hmm nie wiem może problem z windowsem?

Spróbuj jeszcze tej komendy (nie jestem pewien nawet czy jest taka)

sudo dpkg-reconfigure grub

(Attendite) #19
hack@hack:~$ sudo dpkg-reconfigure grub

[sudo] password for hack:

hack@hack:~$ sudo dpkg-reconfigure grub

hack@hack:~$

Czyli.. chyba jest. O co może chodzić ? :frowning:


(matiit) #20

Nie ma teraz windowsa przy startowaniu komputera?