Grub rescue> po instalacji OpenSuse - jak naprawić?


(Robin-Otzi) #1

Instalowałem OpenSuse na czysto,
ręcznie podzieliłem dysk na partycje:

wojtek@linux-fo7q:~> sudo fdisk -l
root’s password:
Dysk /dev/sda: 74,5 GiB, bajtów: 80025280000, sektorów: 156299375
Jednostki: sektorów, czyli 1 * 512 = 512 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512
Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512
Typ etykiety dysku: gpt
Identyfikator dysku: 40261D6E-BED6-4C5F-BE68-BD09D0976E2A

Urządzenie Początek Koniec Sektory Rozmiar Typ
/dev/sda1 2048 8390655 8388608 4G Linux swap
/dev/sda2 8390656 81803263 73412608 35G Microsoft - dane podstawowe
/dev/sda3 81803264 81819647 16384 8M BIOS - rozruchowa

Nie rozumiem sensu partycji BIOS wcześniej miałem Minta i nie robił takich problemów!
Udaje mi się uruchomić system z poziomu płyty CD
(nie Live tylko startuje z płyty i uruchamia system zapisany na dysku)
bez CD daje error:
attempt to read or write outside of disk hd0
grub rescue>

Proszę o pilną pomoc!


(Domker) #2

Źle podzieliłeś dysk na partycje.
Nie tworzysz partycji z system plików NTFS tylko EXT4 - to Linux, a nie Windows.
Przy GPT (UEFI) nie tworzysz partycji rozruchowej BIOS, bo to nie ma najmniejszego sensu tylko partycję rozruchową EFI z systemem plików FAT32 (około 200MB) i to jako pierwszą, a nie ostatnią. Dodatkowo musisz ustawić do niej punkt montowania na “/boot/efi”.
Jeżeli nie chce Ci się czytać poradników / oglądać jak powinno to wyglądać na Youtube, to zostaw partycjonowanie automatowi.

Jak sobie wyobrażasz działanie systemu skoro jest niepoprawnie zainstalowany.
Z płyty Ci się uruchamia ponieważ os-prober wyszukuje Ci system na drugiej partycji.

/dev/sda1 (200MB) - punkt montowania /boot/efi, system plików FAT32 (tu trafi GRUB)
/dev/sda2 (35GB) - punkt montowania “/”, system plików EXT4
/dev/sda3 (1.5x wielkości twojej pamięci RAM, jeżeli planujesz hibernację/usypianie), SWAP

Tak mniej więcej powinien wyglądać podział, aby system Ci działał normalnie.


(Robin-Otzi) #4

To nie ja dzieliłem, tylko sam tak podzielił!
Nawet źle identyfikował system plików, tam nie było NTFS tylko RaiserFS (czy jakoś)

Problem rozwiązał się, gdy zakupiłem dysk SATA podłączony bezpośrednio do płyty głównej!
Ewidentnie Suseł nie radził sobie z zewnętrznym kontrolerem SIIG na PCI.
Mint działał tak bez problemu.