Iframe - problematyczny biały pasek


(andrewi) #1

Hej :slight_smile: tworzę stronę internetową na bazie innej, którą już kiedyś stworzyłem. W obu wypadkach używane były ramki iframe. Tyle że ta pierwsza strona miała białe tło, a ta druga szare i wyszły dziwactwa iframe tzn. biały pasek pod ramką. Wygląda to tak jak na załączonym obrazku. Na pierwszy widać stronę z białym tłem, na drugim z szarym i białe paski.

https://www.dropbox.com/s/iw8rfzij2qevfzy/1.jpg (orginał)

https://www.dropbox.com/s/e5a7tn2x3kgkp0d/2.jpg (po przeróbkach z szarym tłem, chodzi o te paski pod menu bocznymi)

Próbowałem już wszystkiego, przeszukałem masę for i dowiedziałem się tyle, że jest to typowy błąd Internet Explorera... Będę bardzo wdzięczny za pomoc bo te paski są... irytujące.

Poniżej załączam jeszcze kod z pliku index html odpowiadający za te menu oraz cały css strony

#kontener {width:1000px; height:auto; overflow: hidden;}


.menu_index, .menu {margin:8px 4px 8px 3px; float:left;}

.menu_index, .menu, .menu2 {height:auto; width:190px;}

.menu_index, .menu2 {background: #fff; border:0;}

.menu {background:#fff border:solid 1px #00d2f1; border-radius:10px;}

.menu ul {margin:4px 14px; list-style:none;}

.menu li {background:url(images/menu.png) no-repeat 0 9px; padding:6px 0 6px 14px;}

.menu li a{font-size:11px; color:#00d2f1; font-weight:bold;}

.menu2 {margin:8px 3px 8px 4px; float:right;}


.menu_plywajace, .menu_plywajace2, .menu_grupy {float:left; width:190px; border:solid 1px #00d2f1; border-radius:10px;}

.menu_plywajace, .menu_plywajace2 {height:1100px; background:#fff;}

.menu_plywajace ul, .menu_plywajace2 ul {margin:4px 14px; list-style:none;}

.menu_plywajace li, .menu_plywajace2 li {background:url(images/menu.gif) no-repeat 0px 9px; padding:6px 0px 6px 14px;}

.menu_plywajace li a, .menu_plywajace2 li a {font-size:11px;}

.menu_plywajace li a, .menu_plywajace2 li a, .menu_plywajace2 a {color:#00d2f1; font-weight:bold;}

.menu_plywajace hr, .menu_plywajace2 hr {border:0; width:200px; height:2px; background-color:#00d2f1;}

(Gerard Zurek) #2

Przepraszam, ale skoro pozycje itp ustalasz za pomocą css, to czemu nie zrobić tego za pomocą <?php include(‘cokolwiek’); ?> ??

W sensie:

Chyba, że się mylę… ^^

PS.

tylko wtedy wysokość, szerokość itp. musisz ustawic za pomocą css… :slight_smile:

<?php include(‘menu_podreczne.html’);?>

<?php include(‘menu_podreczne_2.html’);?>


(andrewi) #3

To by się sprawdziło na tej białej stronie, tam na serwerze mam obsługę PHP, niestety w przypadku tej szarej serwer jest darmowy i nie obsługuje PHP… Ale dzięki i za Twoją radę :slight_smile:

Temat można zamknąć, poradziłem już sobie z problemem, okazało się, że w css miałem źle zdefiniowany kolor background dla iframe :slight_smile: