Instalacja fglrx 9.3 legacy na kernelu 2.6.31 (xpress 200m)


(foreste) #1

Witam

w jaki sposób zainstalować sterowniki ati fglrx wersji 9.3 legancy na systemie z kernelem 2.6.31(opensuse 11.0),lub sposób na obraz 3D na tej karcie radeon xpress200m w Linux ?.


(Phanyx) #2

Niestety Ati/AMD przestało wspierać swoje karty, które zalicza do Legacy, na kernelach powyżej bodajże 2.6.30.

Możesz spróbować otwartych sterowników RadeonHD. Tu masz stronę tego projektu:

http://www.radeonhd.org

--

Tak czytam sobie to readme dołączone w paczce z wersją 1.3.0 i wygląda na to, że twój GPU nie jest wspierany i przez te stery. Jedyne xpressy, które tam widzę, to Radeon Xpress 1200, Xpress 1250. Więc raczej opcja z radeonhd w tym przypadku odpada.

--

Wygląda na to, że możesz użyć sterownika, który się nazywa xf86-video-ati. Tu masz url:

http://www.x.org/wiki/radeon

Tam jest napisane, że przyśpieszenie graficzne w 3D jest i działa stabilnie.


(Falomir85) #3

jaki błąd Tobie pokazuje??

ostatnio spotkałem się z czymś takim że sterowniki ati chodzą na xorgu<1.7

czyli np na 1.6.5, z pełną akceleracją 3d


(Phanyx) #4

Według mnie problemem jest wersja kernela Linuksa, a nie Xorga.


(Falomir85) #5

phanyx, mam to już przetestowane na laptopie brata i na jednym stacjonarnym

w gentoo nawet zainstalować sterowniki karty się nie chciały, pokazywało błąd w zależnościach

a po drugie teraz na temat....

sterowniki możesz załadować tylko w konsoli przy wyłączonych Xach i GDMie

1.logujesz się na drugiej konsoli na konto root

2.killall -u "TWÓJ USER"

3./etc/init.d/gdm stop

4.no i instalujesz sterowniki ./radeon*.run


(foreste) #6

Nawet stare sterowniki które mają prawie rok na nowym jajku 2.6.31 ? :o


(roobal) #7

Sprawdź w ogóle wspracie sterowników dla wersji kernela, bo z tego co gdzieś kiedyś czytałem, ATI raczej zakończyło wsparcie dla linuksowych sterowników, na którejś tam wersji jądra.

Pozdrawiam!


(foreste) #8

roobal właśnie to pisze tu jak mieć 3D na nowym jajku 2.6.31 bo na 2.6.25 acpi w joybooka a52 mi nie chodzi poprawnie i modem huawei głupawki dostaje :).


(Falomir85) #9

testowałem na 9.8 i 9.9

właśnie znalazłem, że ostatnie wsprarcie jest na https://a248.e.akamai.net/f/674/9206/0/ ... _linux.pdf

czyli catalyst 9.3

roobal, może ręczna kompilacja jądra by coś dała :wink: ??

wiesz czy przypadkiem masz skompilowane jądro ze sterownikiem ati radeon ??

no i jakie błędy Ci pokazuje, bez tego nie będziemy wiedzieć jak szukać rozwiązania

może nie ma sensu wchodzić zbyt głęboko w temat, sprubuj zainstalować ręcznie pobrane sterowniki


(foreste) #10

ati radeon mam skompilowane ale bez 3D

a po instalacji tych sterowników na tym jajku nowym to mam pole czarne przy starcie środowiska graficznego i nic się dzieje potem tylko restart muszę robić i vesa dawać.


(Phanyx) #11

A próbowałeś kompilować ten sterownik, do którego link zapodałem w drugim poście? Z tego co tam jest napisane zapowiada się obiecująco. Jeżeli nie próbowałeś, to zanim rzucisz się w wir walki, to poczytaj tam dość krótki zbiór porad na temat kompilacji tych sterów - najprawdopodobniej zaoszczędzi ci to trochę nerwów.


(Michal Olber) #12

Witam

A może spróbuj tego:

http://thecamels.org/2009/11/08/wsparci ... fedora-12/

Powinno to zadziałać bez problemu :smiley:


(Phanyx) #13

Kolega ma radka na rdzeniu RS480, a nie R600/R700. Ale jeżeli to komuś zadziałało, to życzę powodzenia


(foreste) #14

JA postanowiłem poczekać do opensuse 11.2 one mogą mieć stery do mojej grafiki.


(Michal) #15

Usuń w ogóle sterowniki od ATI. Poszukaj w repo xf86-video-ati i mesa to powinno śmigać aż miło.